Is there a way to bypass the Chaos Vehicle throttle cut?

While drifting my vehicle will cut power the wheels. I find that this happens when the longitudinal speed is low. The faster I go, the more power gets applied to the wheels. Is there a way to bypass/disable this feature of Chaos vehicles?


Perhaps reduce the Engine Brake Effect in Vehicle Movement Component.

Tried that, it has no effect

I think the issue is due to the wheels not touching the ground anymore while drifting. It happens the same for me when I overjump.
One solution for you is to bring down the center of mass, like -10 or something.
You might also want to play around with the Longitudinal threshold in the Wheels BP.

I noticed that when the car is in the air the throttle also cuts. Is there a way to override this in BP so that torque always gets applied to the wheels?

It’s a bug, it wasn’t like that in Early Access. I hope it gets fixed. You should report it to Epic so the more people ask for it the faster it gets addressed.

A BP solution might be adding a boost if the wheels aren’t touching the ground, but I haven’t tried that yet.

i’m no programmer, last time i’ve touched c++ was over 10 years ago in high school. I’m a 3D artist but i’ve been giving a go at chaos vehicles myself in the past few months. I’ve been digging a bit and as far as i understand it the issue relies in the fact that there is no clutch simulation and that the engine RPM is derived from the speed of the wheels - see Transmission.GetEngineRPMFromWheelRPM(WheelRPM) in ChaosWheeledVehicleMovementComponent.cpp i believe.

My understanding is that this is a cheap and quick way to make the car go vroom but at the same time removes entirely the possibility to drift the car or use sliding in any meaningful manner.
My suspicion is that Epic, some dev or anyone with the skills has to modify the source code of chaos vehicles in order to add a clutch and a proper engine RPM simulation. That function is named as if the wheels have a force and their rotation determines the engine RPM so as soon as you start drifting, the wheels slow down, and so the engine, which means less power output, less speed and you slow down to a crawl. RPM dies mid air too because i think the wheels have no surface to have contact with so no force is actually applied and thus they don’t spin. same goes if you are going very fast and suddenly hit the brakes a bit when steering and end up in a spin: the RPMs go negative as does your speed because of the same reason.

I asked around at work (we’re using UE4) and seems like the best way to go is to clone the chaos vehicles plugin so not to edit the original one, add a clutch simulation, add proper engine rpm simulation and set the transmission of forces as it’s supposed to be: engine-drivetrain-wheels (because it seems it’s the opposite of what it’s supposed to be, the way it’s coded right now), and expose a whole bunch of functions and variables to blueprint which are quite vital to prototype a sim racing game with chaos but that are currently not available in the official build.

I wrote to Paulo Souza (he made a video on chaos vehicles on the UE YouTube channel recently) and mentioned this issue, so hopefully we’ll get someone from Epic fixing this or some other dev coming up with a solution, i don’t have enough coding knowledge myself sadly.

1 Like

Seeing as Chaos is still in development, let’s hope epic adds more features and fixes the RPM issue. I guess all we can do is mention the issues and wait for a fix.

Nothing has changed so far. The wheels keep stopping to spin in mid-air.

Sorry, but if you are mid-air, would the wheels spinning or not spinning not be just a purely visual effect?
Yes they would.
Ergo, you built your car wrong/did not follow best practices, as if you had, the wheel material would keep on spinning based on the forward velocity of the vehicle.
The engine sound is also something that doesn’t need physics behind it.

And you definitely cannot apply physics from the wheels while mid-air.
So the beheviour to “cut” is 100% correct. The way you create the model(s) must not be.

Note: I’m in no way defending chaos. It’s pure trash. But let’s be objective.

Re: The drifting causing wheels to go mid-air… well, that’s part of why chaos is trash. You can optimize the vehicle to make it happen less, and try to use substep to further correct it at the cost of performance.
However with chaos you are always going to get around 70% less performance over PhysX, and a lot of inaccurate simulations. Probably always, even when they call it fully functioning instead of beta - which I think they are currently since 5.X has basically shipped with only chaos and they made it incrementally harder to go back to physX via source.

From my testing I’ve noticed that there is a consistent hard limit in the engine simulation to cut torque once the skid magnitude of a driven wheel reaches 30 times the ground speed (Say you have a 28 diameter wheel, you’re pinned to 840 skid magnitude and it’ll PWM the drive torque to hold that limit, 32=960 etc, 30x is the constant factor). When the wheel is in the air theres no ground speed reference and it’ll compare with a ground speed of zero (not quite but more or less), this is why it feels like a soft limiter at around 3000rpm when the wheels aren’t touching the ground in first, barely over idle in 2nd and ofc this changes if you adjust gear ratios.

As far as I can tell it looks like there is traction control logic thats still active even when it’s switched off (or possibly something to do with the arcade stability control features) I think the flaw is isolated to the engine simulation and not a fundamental flaw in the physics/wheels system since you can vastly exceed the skid maginitude under braking/handbrake without ABS (and ofc the slip magnitude under heavy over/understeer is fine too)

Hopefully someone picks up this issue as it’s been in the engine for as long as I’ve been playing with chaos.


I also think it has to do with Traction Control. In UE5 Early Access I didn’t have such a problem!
I can drift without any issues, as long as the wheels keep touching the ground (so just move the center of mass down).

If your wheels aren’t touching the ground they should spin as fast as the RPMs would allow them! This is a Chaos Vehicle issue, not a model setup one.
The sound engine is related to the RPM, which are indeed cut during a jump (wrongfully so).

100% the opposite.
The wheels never spin. The material on the wheels spin based on the vehicle travel velocity.

At least if you follow any best practice at all. If you don’t, then you shouldn’t be wondering why stuff doesn’t work.

No, they wouldn’t, shouldn’t and don’t. If the wheels rotation was entirely based on travel velocity then they would keep spinning while you drove down the road and applied the handbrake. But that doesn’t happen, they quite correctly instantly come to a stop while the fronts keep turning relative to the speed of the surface they are in contact with.

I’m not sure if we’re falling into a loss of translation here or you have a lack of understanding of vehicle dynamics but if we are actually being objective then chaos does handle wheel forces correctly but the engine simulation pulls power when it detects logitudinal slip or doesn’t have a reference point to calculate said slip (i.e when airbourne) when it’s being explicitly told not to do that.

However if you do suspect there is a hack or shortcut that both of us have taken, it would be helpful to express what that might be because just dressing up the phrase “You probably did something wrong” just obfuscates the issue and makes it seem like user error without merit.


The only one with lack of understanding here is you.

Go have a look at existing products and/or develop actual car models for dealerships and commercials.
Talk about it then.

It is. Go study. Theres a billion docmented Epic driven content tutorials/explanations.

The throttle being cut in air seems to have been fixed with 5.2 but it still cuts throttle during hard cornering making it impossible to do any real drifting. At least that’s been my experience. By adjusting the engine torque settings, tire friction and offsetting mass you can get the vehicle to do sideshow style burnouts and powerslides but so far I haven’t been able to get drifting to work (i.e. wheelspin with counter steering) because the throttle cuts out.

That is an issue, but the initial supposition from the above folks was that it was due to the loss of traction leading to lift of the vehicle.

There were several topics on making trails for chaos vehicles on this forum where the parameters to allow for drifting were shown as well as the code needed to get the tire marks going. Things may be different with the recent changes and what not, but it should give you a better idea of what settings to use - assuming your model is not the issue, which it can also be.

I don’t know if it’s actually cutting the throttle, probably more likely the forces on the wheels are bogging it down. Giving the engine massive amounts of torque will keep the wheels spinning but it’s not drivable at that point. I’m using the standard chaos sportscar assets so it shouldn’t be the model. Got the car set up with smoke and tire marks, it’s really fun to do smoky burnouts. Just no drifting. Hopefully that gets fixed soon.

1 Like

After playing around with a few more things I’ve noticed that applying external wheel torques will also lock out to the same skid magnitude limit. Which now seems obvious since this is where the traction control toggles are set so I guess that helps narrow down the problem to the chaos wheels and not the engine sim as I’d incorrectly stated above.

I’ve yet to clone my project to 5.2 but I’ll give that a try and see if theres any changes in behaviour.