Download

Is there a bug with Niagara system? Bullettrail wont go straight

Hi,
is there some bug with the Niagara system?

I followed Code Like Me:s excellent 3p shooter tutorial. In one episode he creates a bullettrace from a niagara fountain system. I could not get it to work properly because like every 10th to 15th shot didnt take a straight line to the target but some really wierd twisted way.

I thought maybe I did something wrong and thought Id give it another shot when I got better understanding of Niagara and how the engine works.

So now I’m doing my own gun blueprint. I do 2 tracelines one from the camera to x-hair and one from the gun to the x-hair.

When I do debug on the one from gun to xhair it always work and show nice straight lines.

I found this UE4 Niagara Tutorial - Ribbon Trail (Bullet Trail) - Intro to Niagara UE4/Unreal Engine 4 - YouTube very nice tutorial on how to make a nice trail. In the video he uses Torus effect to browse the trace but in my final version to make sure it wasn’t the unchecked Toruseffect that messed it up I deleted the torus part in the emitter.

Still I get some shots every now and then that takes some really wierd way from the gun to the target.

Below is a pic where the img to the left show how its supposed to look and to the right how it looks every now and then with some wierd randomly curved line. I can’t figure out why this is happening and wondering if its some form of enginebug?

I tried both types of code to move it:

Well I just solved it myself by putting a do once node in front of the code with reset after deactivate. Maybe it will help someone :slight_smile: