Download

Is MSAA broken in Unreal 4.14?

I’m trying to use the new forward rendering with MSAA in GearVR, on a Galaxy S6. But there’s definitely no antialiasing going on. At all.

After a lot of time searching online and in the editor I found the following variables which potentially could be related to turning MSAA on:

Window > Developer Tools > Device Profiles > Android:

  • r.MSAACount
  • r.MSAACompositingSampleCount
  • r.DefaultFeature.Antialiasing
  • r.MobileOnChipMSAA
  • r.MobileMSAA
  • r.MobileContentScaleFactor

None of the above seem to make a difference if I change them from within the Device Profiles editor within UEd.

Edit > Project Settings > Engine > Rendering > Default Settings > Anti-Aliasing Method:. Setting it to MSAA does nothing.

I also tried setting all of the previous variables from within DefaultEngine.ini and nothing.

There’s got to be something I am overlooking. If anyone has any thoughts I’d really appreciate it.

MSAA on Gear VR is locked. You can’t disable it. Afaik it’s forced by Oculus software, but maybe not.

You’d be better off filing this as a bug on AnswerHub.

OK, will do. Thanks.

My guess is it’s a problem building that way. Mobile exports with UE4 uses forward rendering by default so you do not need to use any special ‘forward rendering’ version of the engine. If you use the default 4.14 engine it uses MSAA by default on the gearvr export (no way to turn it off or on) and the forward rendering pipeline.

If what you say is so, there seems to be a bit of misinformation out there including Epic’s own official announcements. This is the announcement for UE 4.14 : https://www.unrealengine.com/blog/unreal-engine-4-14-released They clearly feature the forward renderer as a new option that needs to be turned on. Though they do not distinguish between mobile and desktop/console. So you might be right that it builds forward for mobile by default. That being said, I did anyway set the forward path on in project settings, which required restarting the engine and recompiling the shaders. But it is not a “forward version” of the engine. It is the same pre compiled version, just the shader pipeline changes. And I tried all of the variables above including the one mentioned in this link. And nothing. So not sure what is going on.