Download

Is lighting broken in unreal or am in dumb?

guys i ain’t a level designer or artist or whatever, so sorry for basic questions.

what I wanted to do is create a hallway and put some lights in it but after i bake the lighting all the lights disappear like there’s was nothing in the first place. I’ve also created a lightmap in blender and exported that into unreal. so here are the results.

Dynamic lights, this is what i wanted to be.


this is after baking wtf?

and this is the lightmap

could someone help what im doing wrong here?

By default the lightmap resolution for an imported static mesh is 64 x 64 which can be pretty low. Also, verify your lightmap UV coordinate index, which sets which UV channel is used for your lightmap. By default when you import to UE4 it will try to automatically generate lightmap UV’s which does a pretty poor job. If you created your own lightmap UV’s then you need to disable that option in the import window otherwise it will create the new channel and set it for the lightmap.

i set the resolution to 512 in blender, and i disabled generate lightmap uv in the static mesh editor.

does it have to be more than 512? isn’t that gonna hurt performance in a long run?

You don’t set the lightmap resolution in your 3D program, you set it in Unreal, you can set it by opening up the mesh from the Content Browser, or you can select the actor in the scene and use the Lightmap Override option. The setting you set in Blender was for spacing out the UV’s to align to the pixels of the lightmap (though that only works for rectangular objects)

512 isn’t that high for a lightmap, but if you’re not seeing anything at 512 then there’s a problem.
Also make sure you’re using the right kind of light, Static lights get entirely baked and can’t affect dynamic objects, stationary lights bake indirect lighting but the direct lighting and shadows is fully dynamic, you just have to make sure to limit the range because only up to 4 stationary lights can overlap.

Blender lightmap resolution doesn’t carry over to Unreal I think.
You need to open up the static mesh in the Unreal engine and set the resolution there.
Also, make sure that the texture coordinate index is the right one where your light map UVs are actually found.

yeah, i didn’t know that before, i hate when 2 softwares are not linked properly cuz going back and forth is a pain in the back.
i ended up increasing the resolution, up to 1024 but I still see some artifacts where there should be a soft shadow, so I might have to look into it a bit more.
do u have any idea what else I could change to improve the shadows? increasing the resolution doesn’t have an effect after some point.

Again, that lightmap setting has nothing to do with linking to UE4, it’s just for the UV layout. No 3D software’s link in that kind of way. In Blender you can use that option so that the edges of your UV’s line up with the pixels of an image, for a lightmap that helps to get cleaner lightmaps with a lower resolution since the edges line up with the pixels. But again it is only usable with rectangular objects because anything that’s not a box can’t line up with the square pixels of a lightmap.

My recommendation is to check the “force no precomputed lighting” button, and mark all your light sources “movable,” and use modern real-time lighting.