Is Layer panel bugged in UE5?

Hi all,

I tried to import landscape and make an ocean using Water plugin in UE5 but I found some problems. One of them is that when I import landscape and enable edit layers in it my ocean seems not to influence landscape. Somwhere on the forum I found kind of solution to this but it requires use of layer panel which doesn’t work. I can not add new layer neither by draging nor by right clicking. It just looks empty and nothing seems to work. Is it bugged only for me?

Same here. Can’t make layers, must be a bug.

1 Like

Has anyone worked out what’s going on with this yet? Not working for me either and cant find anything in the documentation either. This was the only thread I could see talking about it

Hello guys, today I ran into the same problem, but I was able to solve it. They just have to disable the Enable Streaming option within world settings, re-create the level or before you start using layers, disable the option.

Sorry for my English, I’m using the google translator.


has anyone solved this?

Broken here too…
Disabling streaming does not solve it.

hey guys

Using Data Layers, Actors can be dynamically loaded and unloaded in the Level Editor to help manage complex levels. They can be enabled using Blueprints to drive gameplay and are an important tool for managing asset streaming in a World Partition workflow.

Data Layers serves as a replacement for the previous Layers system found in older versions of Unreal Engine.

World Partition - Data Layers in Unreal Engine | Unreal Engine 5.0 Documentation

1 Like

When trying to create a garbage mask in Composure (as per this tutorial - Unreal Tutorial for Composure, Green Screen, ACES Color, Timecode, and Genlock - YouTube) - it seems to require that under Capture Actors you Include a layer - and that apparently can’t be a data layer.

Do you know if there’s an alternative to this?

Can confirm - bug occurs only on Open World template, it works fine if you use Basic template. Still present in UE51 Preview.

Reported it to Epic Games as Case # 00487468: Adding object to Layers doesnt work with Open World level template has been received

Got the answer from Epic:


For questions about how to use Data Layers with World Partition, please visit:—data-layers-in-unreal-engine/.

There you will find community support, free online learning, and documentation as well as other useful links.

Guess they suggest to use Data Layers since it’s a replacement of the older Layers system. But work is still in progress since for example in Composure (Composure Compositing) “Browser Layers” redirect to old Layers instead of Data Layers and that means I have to use Layers there.


Unreal accepted it as issue - Unreal Engine Issues and Bug Tracker (UE-168916)

1 Like

I found the way to fix the bug
and call me big brother I’ll tell you
easy,change the main screen,or drag the editor window to another screen~bingo,you’ll use your layer with your myth face~~
and remember,you own me a “big brother~”

can confirm this was the issue for me

Got the same issue yesterday…

when you create new scene in engine, select basic scene it solved my issues never use prebuilt scenes. Sorry not good in english.