Download

Is judder issue possible to solve?

Hello all!

I’m really disapointed on seeing awesome demos on unity without judder, and simple demos on unreal judding (Last time just e scene with a box floating +70 fps)

My final question is simple, there is some people saying they don’t have any judder! Is this their fault cause they can’t see it? Or there is REALLY a way to get rid of the judder effect?

I even don’t mind about long clarifying answers, i just find a lack of ‘‘No it’s not possible’’’ ‘‘Yes you an, keep trying’’

Thanks guys!

I’ve already done hundreds and hundreds of tests. The result is: there’s no way to solve that so far, or maybe never (unfortunately).

Just to have an idea about the problem:
To run smoothly it’s necessary to have more than 70 fps in RIFT (69 we already have judder, so +70 is a rule) and it’s impossible to reach this number in a nice scene (even the most optimized one).

Simple scenes also give us a very bad FPS. Decreasing the resolution and other things it’s possible to reach 70 fps, but the quality is going to be TERRIBLE.

:frowning:

My solution has been to turn down settings to make sure I can stay at 75 FPS. My machine is rather modest - an Alienware Alpha - so I never expected to run on max settings anyway. I use the ScalabilityUIPlugin (GitHub - Teddy0/ScalabilityUIPlugin: A launcher for UnrealEngine that has graphics performance options) so that I can set graphics settings when my game launches. I can definitely say that at Medium settings on my little Alpha machine I am at 75 fps and experience no judder.

Man, is it possible to show us some screenshots of your scene using the quality you apply to run smoothly in rift?

would be nice if we got smooth experience with 75+ fps … truth is, you need constant 85+ better 95+ … i got scenes wich judder and got 60-70fps with hmd vsync on … if i turn the hmd vsync off, for “performance debugging” it jumps to 75-80fps :slight_smile:
I guess the whole system sync catches some time/fps. My rule of thumb is, 200+fps in 1080p is good for 75+ with the rift.

One thing is bugging me, cant they just give the possibility to run at 60fps/hz by setting? like the DK1, that would be target you could reach in most cases with actual hardware and sp 120+
I hope the consumer model will be sophisticated enough to lower the sync freq. if necessary.

Hi luisrosenstock,

Sure, here are a few videos I’ve posted on YouTube:
https://youtube.com/watch?v=ATkQGcukCgYhttps://youtube.com/watch/3xvFLZI7FYAhttps://youtube.com/watch?v=j2rq2uUfXyE

Granted, I’m a VR enthusiast implementing proofs-of-concept and not a game developer implementing real games, so these examples may not compare to what you are trying to implement in your own games.

i’ve posted some of my judder solutions here:

https://forums.unrealengine.com/showthread.php?2826-Flutter-Bombs&p=254159&viewfull=1#post254159

this may or may not help with what you’re trying to achieve, but it did take quite some time to rebuild this environment for judder-free direct mode. also, extended mode for me is usually better compared to direct, but the hmd mirror is important for shows and public demos.

what system specs are you testing with?

cheers

Hijacking, I’ve said it before but I could get scenes running on “high” with the old runtimes, but not the new ones.

Here’s a screen shot,
3925-12380679-ProjectDeepSpace_ImmersiveHouse01_jpg.jpg

This is exactly what I had running in rift.

I’m using a DK1, and was getting great performance with 4.6… I was forced to update to 4.7.3 and runtime 0.4.4 because I was getting lightmap errors on build that I just couldn’t get rid of, and I wasn’t getting them with the same level in 4.7.3. Now my FPS has dropped by half and I’m getting judder out the wazoo (60fps down from 120fps) and to get SOME of it back I have to lower the quality to at least HMD SP 100, which is unacceptable (and now direct mode doesn’t work.) I was going to order the DK2 but it seems people are having problems with that one as well.

Also the VR preview mode only fills 60% of my screen/rift display from the top left, and I can’t get that to work either.

…ugh