Download

Is it possible to toggle on/off one of MODULES in emitter by bp/sequencer/user parameter?

Hi!
Is it possible to turn on/off modules in emitter using blueprints/sequencer/Niagara user parameter??

I have an emitter where i NEED to have skeletal mesh location sampling in particle update. What i want to do is to blow this particles away from mesh at one point. In worst case scenario i will create another emitter and i will kill particles on first emitter and create and instantaneous blow particles on other but like i said- worst case scenario.

You can do that by just changing another emitter parameter.

So you have ( at least ) two modules, the mesh location, but also ( for example ) a vector noise force module in update.

You keep the default ( of zero ) until you’re ready to ‘explode’, and then set it with a user parameter:

vectornoise

[ Point force is better… ]

Hi and thank You for reply!! :slight_smile:
More or less that is what I’ve tried. Problem is: they are particles on a moving character and in one point i want them to just fall off to the ground. I’ve created a gravity mode, inherid velocity, collision etc and bind them to a user param which i was changing from sequencer. At a given moment they fell off to the ground BUT as a character move, this movement was still transfered to partiicles… :sob:

Turn off local space also.

its already not in local space :smiley:
by moving character I am not talking that i am moving asset on lvl but, this is a walking character who move head, hands etc and that movement is visible on falling particles.

Ok, so you need static mesh location in spawn. Then you can use gravity and stop spawning, and they all will drop. ( I’m thinking you have mesh location in update? )

Yes… this is why i have this problem. i event said it in first post but apparently it was not clear enough. sorry. Hmm maybe i just don’t understand your idea but isn’t that much different from just having another emitter or system that would spawn new fx and let the original die in the same moment?

What I mean is… :slight_smile:

If you have the static mesh location in the spawn section ( not update ), when you stop spawning the particles and give them gravity, they will just fall to the floor, and no longer follow the mesh.

hi! sorry for few days lag in reply. interesting idea… will try it. but one more thing: i am spawning then only once. on the beginning. particles are “glued” to surface since frame one.

Here, I made this system:

It spawns once, on the sphere. I have the gravity module ready, but set to zero. Then I set it to -900:

onetimegrav

hmm. ok… but can You make a skeletal mesh with animations in particle spawn so the particles will stick to surface?

I got it to work with spawning once, but you have to put the module in update for when the mesh moves. Then when you add gravity, the particles slide down, not great.

Probably the easiest way is to just kill the ‘bonding’ system, and just spawn a one-off ‘drop to the floor’ system.

yea… well, thx for help :)) have a good holidays!!!

1 Like

Happy holidays :smiley: