Download

Is it possible to permanently enable r.HZBOcclusion?

I’m having a lot of pop-in with my modular level geometry, which I can easily fix by opening the console and entering r.HZBOcclusion 1, but that’s a pain in the butt to do every time, and not at all feasible for the final packaged build. Is there something I can set, either inside Unreal or in an .ini somewhere, which will just enable HZBOcclusion by default?

You can make a blueprint that on event begin play > execute console command.

Hmm, that seems a bit hacky but it definitely works, thank you! :slight_smile:

Couldn’t you put it into DefaultEngine.ini under [/Script/Engine.RendererSettings]?

Hmm, I think that works! It’s hard to tell whether or not it’s the placebo effect, but I’m pretty sure adding that to the ini reduces pop-in… the syntax is exactly the same as the console, right? So this?

[/Script/Engine.RendererSettings]
r.HZBOcclusion 1

I’d use the same syntax as the other settings, so r.HZBOcclusion=1 or r.HZBOcclusion=true.

Oh hey, that seems to do the trick… thank you! :slight_smile:

Pst, hey @HInoue I am NOT a Coder(Artist) would you mind showing me your code so I can get this running in my project as well please? This doesn’t look quite right. :sweat_smile:

The reference is to a file that is present in the Config directory (i believe). Not the header file ><