Download

Is it possible to disable refraction for certain assets when using ray tracing?

So I have this issue where I’ve built up a niagara smoke emitter using the default sub UV texture. It looks fine in raster mode, but when I turn on ray tracing and leave on refraction, the edges of the sub uv texture end up getting rendered and end up looking really strange.

Is there a way to exclude just that emitter from the ray tracing refraction?

I don´t know about turning it off for certain assets or emitters, but wouldn´t it be easier, if you just turn refraction off for this smoke material? Hook up a parameter to the specular input for that smoke material, and set it to zero. Remember, in raytracing, the refraction is driven by the specular input, NOT by the actual refraction input. And the specular input has a default value bigger than zero, therefore it will come with a default refraction, if the input is left empty.

Or, if you want the smoke have refractions, you could use a mask/texture instead of a parameter, black = no refraction, white = full refraction.

Edit: Ah, have tested it, and the edges are still visible on a fully transparent plane with zero refractions :eek:

Yeah it’s a really odd issue that I can’t seem to figure out. I’ve tried so many different adjustments and can’t get the edges to disappear. I know Quixel just released a sample level (alter of the goddess, or something like that) that has some niagra smoke + ray tracing enabled. Maybe I’ll dig into that and see if I can spot a difference.

Just sounds really, really tedious.

Edit: Oh and thanks the suggestion! I appreciate you giving it a shot.