Is anybody having an issue with frame loss using Windows mixed reality headsets in projects that don't lose frames on a vive or rift?

Recently tried a project of mine on the Samsung odyssey and every 15-20 seconds there is a skip or frame loss that is not there for other headsets. Has anybody experienced this issue or can anybody shed some light on why this might be happening for one headset and not the others?

Just to update

After doing some checks, Unreal engine vr template, which is basically an empty scene, takes 8-11ms to render which is nuts seeing as for VR we cannot go over 11ms. So as a developer I have less than 2ms and sometimes no extra ms’s to work with, otherwise I get frame drops by missing the 11ms/90FPS mark… This is pretty bad, and there are noticeable spikes from the profiler that are present before I even start working on the project. These spikes that are there from the start already put the game below 60FPS and we need 90FPS. How can anybody develope VR on an engine that cant beat 60 FPS initially.

I have a very nice pc with top gear and 1070Nvidea gpu, plus lots of RAM

These spikes are in in GameThread > FrameTime > Deferred Tick Time > FTicker_Tick> Self(FTicker_Tick) and start at 11ms but is at 26 ms by the time GameThread is done.

This is also in 4.17
4.18 as well + has a screen warping issue nobody has solved for WMR
4.19 Freeze issue happening for VR people

I’m seeing these issues also. Haven’t tested enough to tell whether it’s a general issue with the steam layer or specific to UE4. I also haven’t been able to reliably use the two joysticks either but I suspect that is to do with steam vr not mapping them to game pad events.

Hi! Do you have any updates? I’ve stumbled upon same issue

Can’t do that :slight_smile:
Well, that’s sad

That’s not true, almost all our projects runs at 90

Lol switch to Unity. This issue started 6-10 months ago and unreal hasn’t discussed any means of fixing it which is how a lot of their issues go. They don’t fix it and say they’ll have it fixed by the next update, and if they do fix an issue 5 more pop up.

you should have posted as a comment because that is not an answer, you just confirmed the error more. but thanks for doing that

it makes me mad unreal has such terrible vr issues that they try to hide. I’ve contacted a few friends in the industry who made unreal engine vr games and they told me you will never beat 60 fps in unreal for vr. so I was done with unreal, unity works wonders for vr!

sweet thanks :slight_smile: if you have vsynce on it will stick to those otherwise unreal engine stil has dynamic fps but will update the hmd at 90 fps or 45 if it cant make that.

It’s not really running at 90… unless something changed, like I said in the intro, a default unreal scene runs at 8-11ms and with any additional time, you are not making your 90 fps make. This is a scene with no post processing as well. And again like I said I have friends in the industry because im in the industry that worked on FarPoint and other games who when asked confirmed you cannot get higher than 90 fps in unreal for vr.

If you’re getting over 90 you might not be using your profiler correctly, otherwise what are you doing to achieve that, because lots of people are trying to achieve that. Are you testing the fps while running a headset or just running the scene?

I’ll send you an screenshot when I’ll be able.
Also UE4 with VR runs either 45 or 90 FPS, never 60

I have the same problem.

It works in 90FPS in Vive, but falls to 45-60FPS in WindowsMR

A bottleneck is RenderThread?
The total of GPU is seen in 9ms

From little processing omissions with something as trigger
“interleaved reprojection”
But, it operates, and is it the feeling that RenderThread is blocked?

By the way, 90FPS appears in the MR in the extremely light scene.

I also get the frame spiking using the Lenovo Explorer, but a lot less when using a Vive. I have found though turning the scalability to below epic seems to fix it, so I think there is something between the two that might help?
Will also try with the different async motion reprojection options within WMR which might be causing it through the Steam Layer.
Has anyone used the Microsoft branch that allows you to make WMP versions for use directly with WMR instead of through the layer? I’d prefer not to use it but at least would narrow down to if its in the WMR - SteamVR layer.