iOS rendering bug: "Recieve Decal" flag on meshes is ignored.

I found this bug deploying to an iPad Air or iPad 4.1 running iOS 8.3. I was running version 4.9 of the binary editor release from the Launcher.

Steps to reproduce:

  • Create a default map in a new project. No content is needed.
  • Create a simple decal material, just a diffuse texture output is fine.
  • Pace a basic sphere in the default map using the “place” tab and rest it on the ground plane of the default map.
  • Drag the decal material you created into the editor default level and a decal actor will be created.
  • Make the bounding box of the decal actor large enough to touch the floor and high enough to cover the created sphere.
  • Toggle the “Recieve decal” flag on the sphere to off, by default it is on.
  • Play on the p.c. And the sphere does not Recieve the decal that the floor does.
  • Play in the mobile preview and the sphere still receives the decal. This same behavior occurs on the iPad.


Hi TeamKingdom -

Thank you for your report. I was able to reproduce this issue internally and have submitted a bug report to that effect, for reference UE-20960. As we continuing to investigate a solution, I will keep you informed here.

Thank You

Eric Ketchum

Hi, I’m afraid for rendering efficiency reasons on mobile we only support the Receives Decal flag for dynamic/movable actors. If you set the sphere to be Movable it should respect the flag. On mobile we expect the flag mainly be used to prevent static decals projecting onto players.

Hi , thank you for answering the question. I actually found this bug because the decal was showing up on a movable static mesh and I didn’t want that. It works for “Skeletal” meshes but not moveable static meshes, moving platforms or physics objects that bounce around the level for example.

Aha, that shouldn’t be happening! I guess we only tested with skeletal meshes. I’ll update the ticket with the info and get it fixed.


Exact same observation here:
The decal doesn’t project on the skeletal character mesh, but does project on its movable vehicle. (iOS)

Thanks for looking into this!

Hi guys, we fixed this issue yesterday with full support for filtering what objects receive decals on mobile, but unfortunately it’s too late to make it into 4.10 with adequate testing, but the fix will be in 4.11. We’re also rearranging our branches here at the moment so the fix isn’t yet available in GitHub. Let me know if you’re using source code and I’ll see if I can get it to you faster.