IOS game crashes after launch and default splash screen

When I launch my game’s level from the editor to my IOS device, everything compiles and build fine as far as I can see.
But after the splash screen shows, my game crashes. I have been looking into this for some days now, but I cannot figure out why this happens.

I attached the output log from the editor and the crash log from my device.

I really hope that someone can see what’s causing this.
link text
link text

Does it run on Windows?

Yes, it runs, Not as it’s supposed to run… but it runs, no crashes or whatsoever.

I had this same problem on an older Android device because it had not enough RAM on the device to load the engine let alone the game content. Maybe you have exceeded the iPhone’s RAM

That could maybe be the problem. But somehow, it’s fixed now.
I was trying to symbolicate the .crash file from my IOS device, but since I had no .dSYM file, I was not able to… Then I checked two boxes in de IOS project settings which had to do with generating that .dSYM file, and suddenly, it launches.

Weird. No idea why?

Have you tried packaging out the .ipa file and loading onto the device using iTunes? I have found that the launch system can sometimes cause freezes on the splash screen which seem to only be fixable by deleting the “Build” folder in the project directory and deleting the app on the device before re-launching.

I have not tried this, but as posted in another question:

I have found out that rebuilding in Xcode first can also solve the problem of getting crashes after the splash screen.