iOS AR in app screenshot

I’m using the latest version of unreal engine and an iPhone 7 to test on. I don’t code.

I’ve managed, using a number of tutorials to create an augmented reality iPhone app that puts objects into the scene. I’ve created a button and now I’d like that button to take a screenshot and save it to the camera roll.

The only thing I can find on the subjects was here:

It really hasn’t helped me very much. Does anyone know how to do this?

I’m surprised no one else would like to know how to do this. Jump on board if you would!!. Im sure some brainiac must be able to figure it out :wink:

Anyone got this?
Decompress it at (GameRoot)/Plugins----------
Generate ur game project----------
Open .sln and run----------
You can add screenshot component and share component in your blueprint.------------------------------
Use take screen shot or take screen shot in album

Remember to change your boot options in .sln!

I downloaded the library on 4.18, after I enabled the getset plugin, using “screenshot” component, I cannot find any method named “take screen shot”

How did you guys manage to get that plugin working for 4.18?

I always get “try rebuilding from source manually” when following the steps above :frowning:

OK I got it working by making sure the same .h file was always included first in each cpp file.

figured out how to get the functionality working as well. You need to do a normal screenshot using the “SHOT” command and then the screenshot events are triggered that you can pass the image through to the Share function

I will commit this as a pull request in the near future

Sorry can you explain that a bit more (making sure the same .h was always included first in each cpp file). I’m getting the same error of “try rebuilding from source manually”. Thanks in advance.

Check out my pull request for the plugin:

Has all the changes in it to make it work with 4.19

Awesome, thanks for the reply :slight_smile:

Hi so I’m still getting the same error for rebuilding from source manually. I’ve tried Googling several different solutions to no avail. Some people have suggested creating a local plugin folder inside where my project file is?

Would you be able to break down some simple steps as to getting this installed and I can see where I might be going wrong?

So far I’ve placed it into the plugins folder for my version (4.18 for this particular project) and have enabled the plugin within my project. This then prompts the engine to restart and that is when I begin getting rebuild requests.

Thanks so much for both the pull and these steps, really appreciate it. I’ll give it a go in 4.19 in a separate project and see if it helps.

Ah you need the basic 3rd party project plugin setup steps you do not add this to your Unreal engine but rather to your project :slight_smile:
FYI: I’m not sure if my pull request version will work with 4.18 you might need to goto 4.19

  1. Open UE4.19
  2. Create new blank C++ project (note: It is only temporary project and it must be a C++ to get it to compile for your engine version. You can later use this for Blueprint projects though so don’t worry)
  3. create a Plugins folder in the project directory
  4. Copy plugin content into this folder (so {projectFolder}/Plugins/Sharing )
  5. Reopen the project
  6. When it asks to rebuild the plugin for this version of the engine press “Yes”
  7. After it rebuilds and the project open successfully you now have a compiled version of the plugin for that version of Unreal that you can use for other non-C++ projects.
  8. Copy the Plugins folder to your blueprint project - it should open without any warnings
  9. You can now use the plugin as per the instructions in the updated readme in the pull request.

Hope that helps!

Just wanted to provide an update after all your help. Managed to get the plugin going in 4.19, but I’m intrigued to attempt in 4.18 still just to see if I can avoid updating my project version, so I’ll let you know if that works this time round using these instructions.

For someone who has never used a plugin, my advice for anyone following these instructions is to make sure you check your Project Plugin section! (It’s found at the bottom of the plugin scroll bar and if you don’t check there, it’ll look like nothing has happened!)

EDIT Has also built in 4.18 using the same method :slight_smile:

Hi there,

I clicked on the link but how to download all the scripts ?

sorry for my ignorance. I am a noob and no coder.

Thank you

To download the plugin you must connect your Epic account to github. See: Unreal Engine 4 on GitHub - Unreal Engine

Thank you for the replied.

for your info, I had already registered and link my epic account to github.

I only see the “clone and download” button in the CODE tab. but it only available with older version 4.16 and before

in the PULL tab, I do not see the download button ?

do I have to download the 4.16 version from the CODE tab and then manually edit the code like the PULL tab contents ?

Yeah right you need to copy the code over until the maintainer accepts the code changes.

Alternatively I’ve shared my versions of the plugin here:


Note: these links are available for 30 days only.
Note2: I renamed the plugin to iosSharing as I was using an sharing plugin with the same name.


and thank you very much for your patient and kindness.

i’m trying to package the project base on unreal 4.20… but some errors occurred, did you get the same problem?

/Users/skinzart/UE4/Builds/SKINZARTPC/D/Documents/Unreal Projects/KaeroAR_Project/Plugins/iosSharing/Source/iosSharing/Private/iosSharingFunctions.cpp(9,9): fatal error: ‘IOSAppDelegate.h’ file not found