Invisible object casting shadow, is it a bug?

I just unticked the visible property in the rendering tab of an actor, and it’s now invisible but still casting a static shadow after light baking.
The “Cast Hidden Shadow” is turned off. If I untick the “Cast Shadow” property it solves the issue, so is this a known bug, or are invisible objects supposed to cast shadows?

Hi Luis,

If you want it to not be visible during game you also need to check “Actor Hidden in Game.” The visible option is only for the viewport.

Let me know if this works for you! :slight_smile: