Internal Quixel Bridge doesn't See Custom Library Path on another drive

The new internal Quixel Bridge doesn’t see my Custom Library Path that is on another drive. I can’t have it on the default drive, since it is a small solid state drive with very little room. When I go to local it says there is nothing there. But the standalone Quixel Bridge sees the Library.


I was also a bit confused by the UI there.

When you go to your profile in the internal Quixel Bridge (inside UE) and click on Preferences, it shows your library path. You can edit this by manually putting in a custom path.

I had a bit of trouble selecting the text in the text field. A browse button would be appreciated here. :slight_smile:

1 Like

I did this but it is not seeing the library. I am wondering if it is because it is on another drive

I’ve got the same concern/curiosity.
From what I can tell the new plugin grabs already converted to nanite uasset files rather than the normal static meshes.
Though I can confirm Nanite does work wonders on imported Highpoly source meshes.

1 Like

@SnackDragon Yeah in the Megascans Library folder, the internal Bridge produces a “UASSETS” folder which contains all of the 3d Assets downloaded from the internal Bridge.

It seem like there’s no way to import custom Mixes at the moment, even if they’re a 3d Asset. I exported using Disc, the UE4 plugin (was a long shot since its set to 4.26 with no 5.0 option, but I wanted to try it anyway), and to the Library and none of that caused the internal Bridge to see my custom mixes/assets.

Seems like right now the Bridge built into UE5 is just for dragging and dropping Megascans, not for custom content.

You need to redownload assets via UE5 for them to be usable. They made changes to the assets for UE5.

From Quixel Support:

You should have no problems at all changing your Local Library! However, I believe your already downloaded assets from the Bridge desktop application will not sync into UE5, so you’d still have to re-download the assets from within Bridge in UE5 as they have been specifically altered to give you the best experience.

By default, all the assets you download from Bridge inside UE5 are placed in the following location on disk:

Win: C:\Users\Documents\Megascans Library
Mac: ~\Documents\Megascans Library
Linux: ~\Documents\Megascans Library

To change this path, click on the user icon in the top right corner of the Bridge window and select Preferences.
In the Preferences dialog enter the path that you want to save your assets to and click Save.

*This path is the same as the default path for the Bridge desktop application.

Thank you for that; good info to have. Unfortunately, that’s for assets already part of the Megascans library, I believe. If you search through Bridge’s content, you need to download/re-download pre-made assets (like a Cliff 3D asset, for example).

What OP, and myself, are trying to figure out is what to do with custom assets/Mixes.

Normally, one would create a mix in Mixer and export it to the Bridge desktop application. Because this 3D Asset is a local file, there’s no Download option in Bridge because it doesn’t need to download anything; the asset is already there as a file in my drive.

From Bridge, I can then export it to UE4.

In UE5’s Bridge plugin, there is no option to Import either files/zips from a drive or to receive mixes/assets exported from Mixer.

It can’t seem to do Custom files. It can re-download local files from Bridge’s own built-in library, but it won’t register or find Custom ones that individuals make themselves in Mixer.

The problem seems to be that the Bridge desktop application does not import custom assets/mixes as Uassets, but the UE5 Bridge plugin does.

Honestly, the only work around I can see is maybe exporting from the Bridge desktop app to UE4, and then taking those Uassets and migrating them to a UE5 project? I guess that could work?

Yeah, I think at the moment the fastest method is gonna be a combination of migrating content and importing fully exported Mixer content.
I’m going to play around with it some today and I’ll report back.

1 Like

Will try too and see if I can come up with anything.

Hopefully this is just for the current build and custom assets will be more easily imported later on.

Been reading the Doc on it, and it just talks about using the built-in assets as far as I can see.

Quixel Bridge Plugin

I have been using Quixel from the Very beginning. It would take a LONG TIME for me to Re-Download Everything…

1 Like

Same here, plus when I first saw Nanite a year ago I made a point of having it grab the Highpoly source option as well just to be safe.

1 Like

I had the exact same problem, was thinking that UE5ea did not recognize my altered library path. I naively tried to reinstall the bridge plugin via the standalone Bridge app and now I get a pop-up message (see link below) whenever I run the editor :confused:

@EddieChristian If you have a UE4 project, you can at least convert it to UE5 and have those assets in the project files. So you can place and use them as needed.

You just won’t have them in the internal Bridge plugin.

If you want to use them in a new project you need to re-download, which is very inefficient.

@anonymous_user_4c294f51 It’s nothing you did. The Bridge plugin in UE5 just doesn’t recognize local or custom files as well as previously downloaded ones.

Essentially the Bridge plugin for UE5 EA is a completely separate app than the desktop version and it has less functionality.

It’s just there to drag in the pre-built Quixel assets.

I suspect, however, that this will eventually change and be updated. It’s probably this way just for the EA version and for testing purposes.

Not really production ready or even build ready really.

I am having the same problem, “The MegascansPlugin plugin was designed for build 4.26 Attempt to load it anyway?” any updates?

You would think this would direct Megascans to import assets into the correct place (in my case a server with massive storage vs my tiny SSD) but alas it just puts it in Content folder on local anyways.