Download

Interiors seem to small while the size is correct

We have done an interior of an appartment. Everyone who tested the Interior with the Vive is under the impression, the size of the rooms are to small. The room measurments are correct in 3dsmax and are correct in the engine. The room setup is correct. When I try to touch the floor with a controller you hit the floor in realworld exactly where you would hit it in VR. Also the eye height is correct. We build a tape measure in 3D and everything seems to be correct. We also measured the height in realworld. For example we have a table wich is intended to be 70cm high. When you touch it with a virtual controller and we measure the distance from the controller to the floor in realworld, it ´s correct. So everything seems to be correct, yet everyone thinks the rooms are to small. I can only guess this might be caused by the eye distance. Is there a way to change the eye distance in UE4 ? It would be worth a try. I mean I also can imagine that really everything is correct and it´s some psychological effect that´s caused by VR and there is nothing one can do about it :).

If everything is correct, then I think everything is correct. I don’t believe IPD would cause this effect, but with the Vive you adjust that on the headset with the twisty knob. I think the issue comes from being accustomed to seeing things on the 2D screens with a wide angle viewport. Perhaps the narrow FOV is also throwing people off.

Hi netfrag-sam, are you by chance using some sort of arch viz blueprint as well? A client of mine had a similar issue that resulted in “too small environment” and visible distortions caused by an FOV override these blueprints often do.

check that the FOV is not being overriden by anything other than your HMD driver or set it manually to the hardware specification of your headset. (110° for the VIVE I think, +/- variance according to the IPD)

Try that please and let us know how it goes. :slight_smile:

To modify the world to meters scale if you want to make a miniature or huge world:https://docs.unrealengine.com/latest/INT/Platforms/VR/ContentSetup/#vrworldscale

If the IPD is set too high (the dial on the side of your headset), things will appear significantly smaller.
For example: A person has an ipd of 63mm and the Vive is set to 70mm, then everything appears at 90% of its actual size.

Thanks for your suggestions ! I currently don´t have the Vive set up and won´t have for another week as I ´m involved in another project.
@StephaBon @McFretN: I tried that knob and expected to notice a difference but it didn´t really change anything significant.
@AtsK: That sounds like it could solve the problem. I´ll give it a try.
@rubenst: The whole project is build from scratch. But you may have brought me on the right track. I noticed the Camera FOV in my pawn is set to 90°. I ´ll set it to 110° and give it a try.
This is the place to set the FOV for my HMD right ? Or is there any other place I have to look at ?

I also noticed that even after a correct room setup the height of my character differs +/- 5cm. When I start a packaged project sometimes when I touch the floor with a controller it fits perfect, sometimes it´s floating in the air and sometimes it goes beneath it. So maybe I should get myself some highheels and check if a rooms in real world feels different once you´re 5cm larger than usual :wink:

Hi netfrag-sam,

you can of course try it…but as far as I know the HMD system + driver calculates the actual FOV off of your IPD among other things. And the IPD needs to be properly calibrated for each user to give the best experience. Slight variations can have a rather big impact regarding this. The same goes for the eye height, step size, vertical movement (stairs, ramps) etc.

I think I saw a Blueprint or scene template here on the forums (can’t remember exactly which one) where you could change the HMD settings from inside VR to see the effect immediately without having to pop in and out of it.