Interior light bleeding

Hi there.
I just started with Unreal Engine and wanted to create an flat-interior scene. I modeled a mesh in Freecad, exported to blender and created an UV map for that mesh.
I created the UV map with some spacing because I am aware that too close UV maps can produce light bleeding.

I created a empty (architectural) scene and imported the flat-mesh. Its one single mesh.
I set lightmap resolution to 2048 and rebuild lighting in production quality.

The problem is I get some light bleeding through the walls that are facing directly to the sun. So if I move the sun, the light bleeding goes with it.

I made a short video:
Light bleed problem

And that are my project files:
Project files

Any ideas what might be the cause of that light bleeding?

Virtual Shadow maps have problems with thin geometry make sure you have blockers set up at that corner on the outside or extrude the wall out about 10 or more centimeters but when you do that make sure you’re also extruding the corner because some extrusion methods in 3D programs will just go along the normal of the faces and ignore corners or won’t attach them.
Or you could just switch to using Ray traced shadows and that for the most part fixes that problem.

Edit: I’ll download the project a little bit later to verify what I said

1 Like

Can’t tell from your video, but make sure the meshes meet exactly in the corners, any area outside of the corners can bleed inside. Also, check your lightmap resolution, if it’s too low then the pixels of the lightmap will be too big and will bleed lighting.

ok holy bidness. you have that light SUPER bright and i’m not sure why. 75000.0 lux… sure… don’t do that. luckily having that room all one mesh isn’t super bad but its still not good to be doing. each wall and floor should be their own mesh with thickness to them.

i know it doesn’t solve your lightmapping issue but by using lumen and adjusting things to be more correct you can easily have a way better looking scene.

(5) Unreal Engine 5 2021 08 31 17 52 56 04 - YouTube

1 Like

, post:4, topic:248152"]
that light SUPER bright and i’m not sure why. 75000.0 lux… sure… don’t do that.

Thank you. That number is set by default if I create an “Empty Architectural” Scene…

Interestingly I had some issues opening your edited scene but I think this is because I am on Linux.
And, your scene still shows light bleed, again exactly on the opposite side where the sun shines at.

But I found out that inside the SunSky and in its Directional Light options there is an option called “Shadow Bias”. That is the only parameter that seems to directly influence that bleeding. If I turn that down from 0.5 to about 0.2 the bleeding dissapears… But I guess that’s rather tweaking than solving the cause.

Video NavJack27 Scene

, post:4, topic:248152"]
each wall and floor should be their own mesh with thickness to them.
I had this in mind often but I thought before I go through the effort of separating the mesh into peaces I’ll try one mesh. But I think I’ll try this, also because of texturing which might be easier with separated objects and their own UV map…

That model seems waterproofed to me.

its 2048, I think this is already more than what I’ve seen so far in other demo projects. I cant imagine that this is the cause because if I decrease it to something about 256 it does not really affect the bleeding.

Another question arises. If I separate the mesh into peaces how can I accomplish soft corners. I’ve seen many recommendations in videos that say “reallity is not perfect, corners are not sharp, scenes look way more natural of corners are not totally sharp”. And so I beveled some corners. But if I divide every wall and floor I get very sharp corners and there will be no more bevel.

You might be having an issue opening up mine because yes you’re on Linux and I’m using ue5 main and not ea2.

And about the curved corner thing: just have a corner section. You don’t need to go as deep as having each column of faces being its own object. As long as all of the walls aren’t all one thing that should be fine but that’s for Lumen but you’re on Linux so you’re not using that. So pretty much dismiss everything that I’ve said because you’re still using the old Shadow maps I believe and light mapping.