Intellisense not working on my project files

I tried out the new visual studio 2015 and Unreal 4.10 Preview 1 and i noticed that intellisense only works on the base unreal 4 engine classes and functions.
Whenever i add a new class, for example a child of ACharacter class, and create some variables and functions it wont recognize. It will only recognize the functions in ACharacter but tell me that all my own functions and variables isn’t defined and the “red error underlining” is dominating my entire view.
However it will compile just fine.

Hey Eqric-

There are a number of UE specific things happening behind the scenes when a code project is created/compiled that Intellisense may not recognize. These “false positives” can be misleading and in many cases can be ignored. You can use Visual Assist alongside Intellisense for code completion or you can use it in place of Intellisense to avoid seeing the false errors completely.


Doug Wilson

for people who is having problems with IntelliSense, my problem might help some others.
My IntelliSense was working on x86 but not x64

I tried everything to solve it but what had really happened was that I had overwritten the file “C:\Users\username\AppData\Local\Microsoft\MSBuild\v4.0\ Microsoft.Cpp.x64.user.props
with the content from a colleague to build other project.

I added these lines which are the ones which screwed up my x64 Intellisense…


So all I had to do was to REMOVE THEM

From which file did you remove " <\AdditionalIncludeDirectories> <\ClCompile> <\ItemDefinitionGroup>"?

From “C:\Users\username\AppData\Local\Microsoft\MSBuild\v4.0\ Microsoft.Cpp.x64.user.props”