Instanced Static Meshes render without material

When I try to spawn an instanced static mesh, all instances are always rendered without their materials, only the standard grey checker material is shown. What am I missing here?
I have also tried to manually set the material after spawning, but that gets ignored as well.

Also, is it possible to access instances after spawning to change their position?

The BP used to spawn an instanced mesh:

How it shows up ingame:

Does you mesh already have a material on it?

If you right click on the Return Value of you spawn node, you can Promote to Variable. This will let you access it later.

Thanks for the answer, I had the material set.
But the instanced-usage flag was set automatically set by the UE4 editor (I guess after using it for an instanced mesh). After deleting and recreating the material and setting the the instanced-usage flag manually it did work.

But I still don’t know how to change the transform of the instances after adding them, is it even possible?

There is a node “Set instance transform”

Check “Used with Instanced Static Meshes” in Material

8 Likes

Thank you