Installer fails at directx and other problems

So, when trying to install from the msi, it stops at the DirectX part, tells me there is an error with the Windows Installer package and rolls back. I’ve tried the workaround where I install DirectX and then disable the DirectX installer in the msi, and it seems to work fine. Then I can click on the launcher shortcut, but then what happens is it downloads ~90 mb and then throws error code 1603. I’ve tried manually installing the prerequisites, but the installer always fails. Windows is up to date, I can’t uninstall any VS 2015 redists as I don’t have any installed past 2013, and I’m running everything as an admin. I even made sure to take full permissions of the appdata/temp folder.

Any ideas?

The msi installer log is here:

I had the Unreal Engine installed previously on a different hard drive, but bought a new one, and this is a fresh Windows 10 install with everything updated, so no old registry entries for it or anything.

Did tons more reading and tried installing the 2015 Visual C++ Runtime and repairing all the other runtimes. Still the same problem.

I forced directX off again and it installed the launcher, but I am once again getting error 1603 when trying to start the launcher. Here are the launcher logs.

Ok, so I tracked a bit more information down and it looks like in the logs, the executable that is causing the Launcher to fail with code 1603 is D:\Epic Games\Launcher\Portal\SelfUpdateStaging\Install\Portal\Extras\Redist\LauncherPrereqSetup_x64.exe

If I run that as admin, it fails with error code 0x80070643 - Fatal error during installation.

You are correct, the launcher’s prerequisite installer is currently failing to install DirectX on your system. At the moment we do not have a workaround but the next launcher release will have a way for you to get past this problem.

So LauncherPrereqSetup_x64.exe is still trying and failing to install DirectX even though the initial msi tries to do that anyway?

Am I having the same issue as this thread?

And if so, I noticed in the answer provided in summer of 2014 that there would be something added to the launcher to fix this issue. Are we still waiting for that same solution?

I fixed it. I don’t know how this happened, on a fresh install of Windows 10 no less, but somehow my permissions were completely screwed.

Here is the steps I used to have everything install correctly without anymore 1603 errors or DirectX fails:

Open My Computer and right click on the system drive (C: in my case, even though I was installing it to D:), click on Properties.

Click on the Security tab, and then click on Advanced. Ensure the SYSTEM user is there and that it has Full Permissions (mine did, so I didn’t think anything was wrong).

Even if it already has Full Permissions, click on “Change Permissions” on the bottom with the UAV shield icon on it.

On the bottom of this screen, after ensuring SYSTEM has full permissions, check the box at the bottom that says “Replace all child object permission entries with inheritable permission entries from this object.”

Click Apply and it might ask you to once again grant it permission and then it will go through all files and folders on your system drive and re-apply those permissions.

It will throw errors about the pagefile and other things saying it can’t modify those, which is fine. Those are all files that are currently in use by the system and don’t want to touch those anyway.

After it completes, or during it may say the Recycle Bin has become corrupted and you will need to empty it. Go ahead and click OK and everything should be good to go.

Like I said, there isn’t any reason a fresh install of Windows shouldn’t have the System account have full access to everything. It’s really weird. Hopefully the admins here can add this to their toolkit to help with people experiencing these weird errors.

@kenjamin DirectX is having the same issue as the thread you linked. It is exiting with an error code of -9. There have been many changes to the install processes since 2014 so the fix outlined there is only partially complete in your case. As I mentioned above, we don’t have a workaround with the current launcher setup. I will add something that will let you bypass the problem. It will be available next launcher release.

So LauncherPrereqSetup_x64.exe is still trying and failing to install DirectX even though the initial msi tries to do that anyway?

At the moment, yes. It is the nature of installing DirectX.