Inspecting Child Actor in Outliner jumps to parent?

When I click on a child actor instance in the Outliner the parent actor becomes selected instead, consequently i cannot view the Details of the child actor. Anyone know why this occurs and if it can be worked around somehow?

This doesn’t help sorry. A child actor instance is an actor, not a component:

An actor can contain a child actor component (which is a component), a child actor component contains a child actor instance (which is an actor):

Parent Actor  (AActor)
    --> Child Actor Component (UActorComponent)
        --> Child Actor (AActor)

Whether or not “Show/Hide Actor Components” is checked in the Outliner, the child actor instance is always shown in the Outliner indented under its parent actor instance, and the effect of clicking on the child actor in the outliner causes the parent actor to become selected.

You can reproduce this as follows:

  1. Create two actor blueprints BP_ParentActor and BP_ChildActor
  2. Add a Child Actor Component to BP_ParentActor
  3. Select the Child Actor Component and set the Child Actor Class field to BP_ChildActor
  4. Add an instance of BP_ParentActor to a map
  5. In the outliner you will see BP_ParentActor and indented under it BP_ChildActor
  6. Click on BP_ChildActor in the Outliner, BP_ParentActor will become selected instead.

There is a flag in UPrimitiveComponent (C++, Components including the StaticMeshComponent derive from it) called bSelectInEditor which I’m assuming would do that…

But the child actor is not a component (it’s an actor), so it doesn’t have this flag. I don’t think the flag is related to the problem.

The ChildActor, if it’s a StaticMesh actor has a StaticMeshComponent (GetStaticMeshComponent()) - I was wondering if it would be possible to set bSelectable to true in that - I tried and they’re still not selectable.

I think you’ll need to select the actor in the world, then in the details panel, select the components in that outliner - you can get the details from there.