Initialize stuck at 72% - no errors cpu at 0%

  1. Left project loading over 10 hours no chance.
  2. Cleaned project (it’s c++ based on 3rd person)
  3. Can build it in just visual studio.
  4. Still no change.
  5. Last major change in project was creating a blue print child of mygamemode (c++) setting it as project default game mode. And doing the same for my gamestate.

No error or logs appear to be produced.

Can you open any other projects? For example, a fresh template.

If not, your problem seems strangely similar to an issue I had a while ago, except it was just an outright crash at that percent. No seemingly logical reason. What ultimately worked for me was cloning my project and replacing the old one. After verifying all my 檔iles and making sure 每verything was working fine, I removed the old, broken project with the cloned version. Following that, everything worked fine. Seems like it was just something wonky on the engine’s side.

Worst case, this is an easy check you can do since you can just try opening the cloned project without any other hassle or time investment.

I can open other projects ok, I’ll try cloning it

No dice with cloning, in the progress of recreating it as it’s happened to a blueprint version of the same game. Starting a new project .

Will be doing the following:

  1. Third person blueprint example
  2. Add a c++ mygamemode
  3. Add a c++ my playerstate
  4. Add a c++ my playerstart
  5. Create a child of mygamemode as blue print.
  6. Set the child blueprint of game mode to the default game mode.

As this is the basis of what I want for my project.

Not sure if this alone is the problem yet or the code I add to them. I’ll document my findings

I’ve narrowed down the problem.

To create these conditions in a project the following will be a condition to create it.

  1. You call a blueprint child of your game mode which has a header such as this in the c++ gamemode.

//// GibballGameMode.h


 // If I comment this out and the implementation of it in the cpp it will load the project.

 AGibballGameMode(const FObjectInitializer& ObjectInitializer);

//// GibballGameMode.cpp (this had to be commented out in order to load as well…)

AGibballGameMode::AGibballGameMode(const FObjectInitializer & ObjectInitializer)
: Super(ObjectInitializer)

// set default pawn class to our Blueprinted character
static ConstructorHelpers::FClassFinder<APawn> PlayerPawnClassFinder(TEXT("/Game/Player/BP_Player"));
DefaultPawnClass = PlayerPawnClassFinder.Class;	

// use our customer HUD Class.s
HUDClass = AMyHUD::StaticClass();

PlayerControllerClass = AMyPlayerController::StaticClass();

PlayerStateClass = AMyPlayerState::StaticClass();	

GameStateClass = AMyGameState::StaticClass();
bDelayedStart = true;


My findings conclude that there is a conflict with the Blueprint Child of Game mode calling the StaticClass which causes the editor whom when a blue print is the game mode no longer protects the overrides. perhaps causing an infinite loop, one is waiting for the other?

So far I believe i can accomplish what i want now.

PS. this is UE4.11.2

Problem persists in 4.14.2. Just removed the Game Mode child BP class from content and it initialised fine.