Infinite Redirect

I am trying to access the creator but it just infinitely redirects me to the same page (I have early access) – I have tried this on Chrome, Edge, and Firefox and run into the same problem. Please help!


This is the same issue talked about here :

I’m experiencing the same

1 Like

same issue here

Yep. Same here!

same here

Same issue as well. Had infinite redirect on both Firefox and Chrome on ubuntu 20.04. What’re the rest of you using?

same, I’m guessing there’s currently no fix?


I’ve tried launching MetaHuman Creator on Firefox, edge, and google chrome but every time I click the link provided by the early access email it is just an infinite redirect loop. I’ve seen multiple other people have the same issue but it doesn’t seem to be fixed.

Welcome to the community, everyone!

We apologize for the issues regarding signing up and gaining access to MetaHuman Creator. There was a service issue that has now been resolved. You should be able to gain access now- providing you are logged into your account.


1 Like

I tried logging in today and found myself in the infinite redirect loop. Did something go wrong?

Hi, I’m getting the issue now. Is there any known solution? Thanks!

I am getting the infinite loop now

Hi, having this infinite loop problem. Tried everything but still not working.

Issue stills exists. Tried all different browsers, tried to revoke metahuman from account, still same issue. After giving access it never gives you the form ur supposed to fill and loops back. A friend tried and all went well. It seems that after it bugs on your account ur stuck. Can you look into issue?

Also just wanted to add, that the first time i launched the app was using Firefox v100, when it displayed the message that this browser may not be compatible. I was thinking, well maybe, i try another later if it doesn’t work. Thing is, this message never appeared again. Hope it helps to debug the issue.

Sir m still having the issue,when i logged in to my browser with the account it kept refreshing the page on and on,but when i logged the same account with same browser in my friend’s laptop it worked fine,then what’s the problem here?

Yeah I’ve been reloading for a week now
still no luck
I think the servers must be crowded!

Found the answer to my case
I disabled my browser AdBlock
and it worked !!!

If you’re curious, it was my ad blocker blocking Once I whitelisted it the epic games launcher fired right up. …

Go to chrome settings-privacy&security-security-and select no protection.