Download

Indoor Sun Light

Hey Everyone,

So I made a building and I’m having a bit of trouble with the lighting. To be more specific the sun light. So I want to have the sun be the primary source of light inside the building, basically how it is in the real world. How you have the sun and the light naturally fills the space even if the room doesn’t have a window directly facing the sun. I’ve spent the last few days playing with all of the settings and have got the indoor light levels about where I want them. So I have two main questions.

  1. What kind of settings do people use to get the nice sun light effect? I’ve been playing with diffuse boost and things like that. I don’t know if this is the right way to go about it, so any advice would be helpful.

  2. My meshes have been shading kinda weird were one is lighter and the other darker even tho they are right next to each other and the same exact mesh. I’ve attached a screen to show it. Why am i getting this? Is it because my light maps aren’t set up well or is because I’m using diffuse boost? Any help on this would be great as well.

Thanks.

Screen2.jpg

Hi,

This is caused by lightmass rendering the meshes in separate threads, using incomplete irradiance caches for interpolation in the process.

Cheers,
klaus

Also sunlight alone wont be enough to lit interior. You’ll need additional light sources for extra bounces. Check out Realistic Rendering project and Koola’s free arch-viz project from Marketplace to figure out how to achieve good interior lighting.

Hey Klaus,

I really dint get what you are saying! Can you please elaborate? I had this problem few weeks ago. How to disable or force to stop lightmass rendering in sperate threads. Any links or previous post explaing this thing?

Cheers,

Jalay

Hi,

No problem.
When lightmass looks for how to shade a certain point, it looks around for neighboring points and interpolates from them. If at that point in time, the neighboring point is rendered by a separate thread and not complete yet, the interpolation is then based on incomplete data. When the neighboring point is finally lit, the shading difference becomes appearent.
This is not so much an intrinsic effect of the shading calculation but more of an optimization artefact from the unlucky use of intermediate data.
If no interpolation would be used, meaning exhaustive raytracing for the whole scene a la POVRay, VRay, etc, you would not have these artefacts but substantially longer build times.
From the above it can be seen that there is no real workaround available, albeit the rather theoretic option of running UE4 on a single core CPU machine.
This might be worth reading: https://forums.unrealengine.com/showthread.php?8491-Baked-Lighting-Variation-Between-Static-Meshes

Cheers,
Klaus

Both of this projects have lighting artifacts, just not so strongly marked.

Yes, but it is inevitable to get some blotches here and there and it will get worse if you try to light the interior with directional light only.

You might want to try adding a skylight to your scene (just chuck it in your scene - no real setup required). I’ve had alright results lighting an interior with moonlight and a skylight although you may need to up the light bounces and bounce light quality in lightmass settings etc. Also if you haven’t already use a lightmass importance volume if it suits your scene.

Hey guys,

Sorry for the late reply. I’ve been busy with work and friends from out of town staying over.

First of all thanks so muchfor the replies. I remade my meshes so that they are larger and a wall only requires only one mesh. Because klaus said there is no real work around. This has been working great. My other question is that I’ve been playing with diffuse boost to get the effect that I want with no other added lights. So what I’m wondering is, is there any downside to doing it this way? I mean I’ve only made a few buildings and it seems to be working. However is this more performance heavy then adding in lights to each building? What are the downsides if any?

Thanks
Taylor

Im not sure, but driving the diffuse beyond 1 makes you loose contrast.
However I may confuse that with “Emissive” at the moment…

Cool, thanks klaus