Indirect shadow for archviz problem

Hi guy!

First,sorry for my bad english…:frowning:

Well,i have a probleme with a indirect shadow in my archviz rendering.
On my picture at number “1” i have a really great indirect shadow.Very nice!
But at “2” i have no indirect shadow,the chair fly…It’s a probleme for get a good realistic rendering…

I have change the scale to world setting to 0.9…0.8…0.5…0.2…0.1!..i have change the smooth to 0.6…I have build to preview,medium,production…but i have all ready the same probleme.He dont’s cast a indirect shadow to the small object…

Thanks for help!

9e33e537e69c1237449feba33ad85d33d5a5240b.jpeg

chairs static object?
What is map resolution light floor? need 512 or 1024
set lightmass:

St.light level scale 0.5 or 0.3
Num inderect L. Buonces 100
Inderect L Quality 7 or 10
Smoothness 0.5

in BaseLightmass.ini

[DevOptions.StaticLightingProductionQuality]
NumShadowRaysScale=32
NumPenumbraShadowRaysScale=64
ApproximateHighResTexelsPerMaxTransitionDistanceScale=9
MinDistanceFieldUpsampleFactor=7
NumHemisphereSamplesScale=64
NumImportanceSearchPhotonsScale=6
NumDirectPhotonsScale=32
DirectPhotonSearchDistanceScale=.5
NumIndirectPhotonPathsScale=32
NumIndirectPhotonsScale=64
NumIndirectIrradiancePhotonsScale=32
RecordRadiusScaleScale=.45
InterpolationMaxAngleScale=.75
IrradianceCacheSmoothFactor=.75
NumAdaptiveRefinementLevels=3
AdaptiveBrightnessThresholdScale=.25
AdaptiveFirstBouncePhotonConeAngleScale=2.5

(Koola set.)

Build as “Production”

time of build= 1-10h or (2 -3 days of scene difficulty)

I’m building an exterior scene with these koola settings and I have quite a few 1024 lightmaps…after like 4 hours it was still at 8% :frowning: My indirect lighting quality is only set to 4 :open_mouth:

@OP, my guess is that you don’t have a strong enough direct light (if you even have one) or there’s not enough bounces of indirect illumination. Table is massive and dark while chair stays are thin and reflective. If your floor is a mesh try a 2048 lightmap resolution and if it’s a brush try 1.

Is someone willing to post the default ‘‘epic’’ lightmass settings values from the .ini? I replaced with koola’s without making a backup… or can I just delete it and it will regenerate a new .ini?

How big of a difference the scale of the lighting will make on the quality of shadows? Have you done some tests?

As subdivs at vray.
density calculation

default vs Koola as “very low” vs “Very High” at vray

try it.
i use this set.
this is the highest quality \ time
result:

St.light level scale 0.3
Num inderect L. Buonces 100
Inderect L Quality 10
Smoothness 0.3
Koola .ini
5c224a88c61fcc9f36386d8314aed96cc66fa676.jpeg

St.light level scale 1
Num inderect L. Buonces 100
Inderect L Quality 7
Smoothness 1
Koola .ini

thank you very much Taxi I’ll try that…i’m starting to get decent shadowing.

My WIP : This was done with default production settings and lightmass set to 0.6 / 100 bounces / 7 / 0.6 (about 3 hours to build iirc, on a i7 2600)
Koola’s settings we’re taking way too long. I have 171 lightmaps ranging between 64 and 1024. :-S

It’s the new tamayo museum I’m making in ue4
cd93b6f167137902280124e2fd3a25feeb4c3314.jpeg

:smiley:
settings for final build)

Tried your .3 100 10 .3…with standard prod. after about 5 hours = 16% ****…gonna take a while with koola’s on top of it. Might try to configure some pc’s for the swarm agent to help it hehe.

my max build - 3 days

holy!!! On a single cpu I guess? what kind?

i7-4930
32GB RAM

Quick question for you TAXI! With your current settings, do you have compressed or uncompressed lightmaps in your lightmass settings? Uncompressed LM crash my pc because I only have 8gb of ram at the moment.

compress

add more ram, 8 is baby shoes for adults
I spend 27 on large projects