Download

Incredibly annoying material bug

I have a seemingly rare bug that constantly follows me around and will not leave me alone.
Whenever i drag a texture into a texture sampler (Shown as image below) it simply refuses, it shows the green border as if it would normally accept it, but whenever i try to drag it in, it simply just doesn’t accept it.
The only exception is textures i have added BEFORE the last time the engine has restarted/shut down

All the fixes i have tried (No im not being dumb and trying to drag something like a color texture into a B&W sampler or a cubemap into a non-cubemap sampler, this would work perfectly on your system.)
A: Restarting the engine (Which causes it in the first place)
B: Restarting my pc
C: Reinstalling the whole engine
D: Waiting for multiple UE updates
E: Literally having a brand new computer built from scratch, not a single part of the old one (Not even the ram) and completely fresh installs of everything (Including OS) and was never connected to the old one in any way except porting a few UE files over AND IT STILL WONT LEAVE!?
F: Yes i did try making another project. No it didnt help.

I have been dealing with this for over a year and it obviously is not user error as i have tried taking a pre-existing project, clearing a sampler, and then dragging the same exact texture without editing it in any shape or form, and it flat out refuses despite it being there a second ago. This is ridiculous.