Download

Increasing .hdr resolution, ray traced shadows artifacts, permanently cap fps

Hey, I have few questions:

  1. when I load .hdr file I cannot set the resolution above 4k. I have googled for a solution, they do not seem to work (editing BaseDeviceProfiles.ini, renaming to DefaultDeviceProfiles, copying it into my project). The resolution is still capped:
    Przechwytywanie.jpg

Another question linked to this - if I were to load 32k hdr - does the engine calculate lighting based on the oryginal resolution or the one that it is capped to?

  1. How can I cap my framerate to x value? When I open a project I always have to type t.MaxFPS x. I did put it into ConsoleVariables.ini but to no avail.

  2. When using ray traced shadows I have some visual bugs when samples are set above 1:

    what could be causing this? The shadows are cast by a directional light, I have one PostProcessVolume in this scene. If I get super close - these artifacts are gone, I have looked for some console settings but could not find anything.

Thanks for the help!

I don’t know if Unreal Engine is capable of outputting 32K! Barely any monitors support it unless they’re specially made, and are probably ultra expensive currently. There’s a cvar, r.AllowHDR, is it set to 1 for the project(s)? I think it is the same as the project settings option, but not sure.

The Max In-Game resolution should be the same as the Imported resolution. So, I see what you are saying about it not changing the cap to 8K. There is a way to change it, but I don’t remember so I’m going to check into it and report back.

As far as HDR, try double checking the different prerequisites / guidelines needed to get it working in Unreal on the page:

Yeah, I am not going to import 32k texture, just gave an example because I want to know which resolution is taken into account by the engine to calculate the lighting - there is a difference when it samples 4k vs 8k, especially if the texture has bright sun. I am also not interested in displaying HDR, I do not even have a screen capable of doing that, it’s just the cubemap used for environment lighting that has .hdr extension. I will also double check if this resolution cap happens only with .hdr files, I did import regular 8k .jpg texture and it was not capped. Thanks for looking into that!

It could be the .hdr extension. According to the doc, it needs to be set to NoMipMaps, but I’ve changed that to sharpen and blur and others in the list and it didn’t screw it up in the scene. It’s probable the .hdr cubemap that isn’t working for Max In-Game Res had restrictive settings on export or creation. There’s a link to cubemaps from the HDRI doc page, and getting a different one there could work.

I have tested it with several .hdr files, the outcome is always the same. I doubt the metadata of hdr contains any information that would make it restrictive upon loading, they work with other engines without problems. As for no mips - this is what I set it to, it is visible on the screenshot.

Your HDRI is not 4k resolution, it is 4k PER SIDE. 4k x 6 sides.

makes sense, after all it is a cube map. Can I make it 8k per side? I can load normal 8k textures without a problem. When I set max texture resolution to 8k the editor crashes, mind that I have enough vram left (around 20GB)

Honestly I’m not sure, theoretically I feel like it should be possible, there may be other settings related to the texture budget that have to be changed to accommodate textures in the gigabytes. Perhaps disabling texture streaming.

I just tested this, it looks like a bug in 4.25, but it is fixed in 4.26 preview.