Download

Incorrect Normals in textures

Newb here. Creating basic materials from megascans. Starting basic with just the albedo and the normal. But where it should be high is low and vice versa. Only solution ive seen is to flip the green channel and that was already selected. I think theres probably something silly thats messed up as this should be very simple. I wouldnt think it should be a grand complicated process to build a material. Any ideas would be appreciated.
Thanks

That’s Unreal material editor for you, lol. You should post the material graph so far, and perhaps the basic settings for it (at lower left in material editor when nothing is selected in the graph). What megascan texture / material is containing the problem?

Thank you,
I was trying roofs, one was ‘Mossy Internit Roof’, Roof_tlmmdikg was the other one, its the first one that came up on my roof search. All I did was create the material, open the editor, add the albedo and connect it and add the normal and connect it. When I saw it wasnt working I opened up the normal to check that the green channel was reversed and it was already. Ive watched a couple tutorials and all they do is drag the normal in and connect it to normal and it works. probably a really simple embarassing mistake on my part.

Did you try unchecking it? Not all normal maps need a flipped green channel, if it was already exported flipped by your application then it should be left unchecked.

Yes, I unchecked it and made no difference. I created two based on walls from megascans and they came out beautifull. I noticed that if I just look at the normal I can tell if it works or not. If the normal is reversed from what I want then it will work. So if the low areas are sticking out i know they will be in when I setup the material. maybe just something about roofs.