Incorrect directional lighting

Hi Guys,

I’ve asked this question before and I’ve recreated my problem.

When I import my static mesh the direct light isn’t casting shadows correctly (as attached). Curiously, a skylight seems to be accurate (as attached).

At the moment the walls are just planes. I’ve established if I give thickness to the walls in 3ds Max, and reimport it lights correctly. I’ve selected “double sided geometry” in the content browser but it doesnt make a difference.

The obvious answer would be to give thickness to all my plane geometry but that would require me to adjust the UV’s to give more space to the geometry visible and I’d like to have the process of importing meshes as seamless as possible.


On the static mesh there should be an option to “Cast shadow as two sided”. Or you can set Two sided on the Material you apply to your static mesh. In the first case, the object will still only be one sided, but the shadow will be two sided. Where as in the second case the Shadow and the object will be two sided.

That does the trick!