Download

In Unreal 4.27 How do we enable settings for Path Tracer in Render Queue

Hello;

In UE 4.27 Preview we add Path Tracer to Render Queue settings and turn it on.

The Render Queue does use path tracer.

How-ever it does not use the PathTracer settings contained within the PostProcessVolumne in the level.

Also the Path Tracer in settings in the Render Que does not appear to have any settings.

We testing by having our path tracer settings in the posprocess volume have very high samples per pixel. Everything looked right in the viewport.

But when we render it behaves as if pathtracer has 1 sample per pixel and zero denoising.

Any help is greatly appreciated

You have to add the Anti Aliasing setting and increase the Spatial Sample Count inside the Movie Render Queue which should be similar to changing the sample count in the Post Process Volume. Although that’s what Epic instruct you to do as per the documentation, I’ve also tried increasing the Temporal Sample Count and found it does effect the image as well so I’m not too sure what the correct procedure is to match your viewport 1:1.

2 Likes

I was having similar issues, and not having any luck using the anti-aliasing settings to replicate the lovely visual in my viewport. The work-around I found is using the legacy movie renderer from the sequencer – it includes the settings needed to get a good result from the pathtracer. Hopefully soon the movie render queue will as well…

This video explains pretty well, how you use the Pathtracer with Movie Render Queue and what to keep an eye on, and some tips for settings:

2 Likes

Thats about as good as it can get for solutions. Many thanks :slight_smile: