Download

In 4.11 "VR Preview" not displaying in Oculus DK2 - just black

When I hit VR Preview I just get black in the HMD. The on-screen preview pane looks right, and responds to HMD movement correctly, but nothing is displayed on the Rift display. As far as I know, nothing has changed since yesterday when all of this worked correctly. Anyone else having this problem?

  • UE 4.11.0
  • Oculus Home (SDK 1.3)
  • Oculus Rift DK2
  • GTX 980 Ti with 361.91 drivers
  • Windows 10

Thanks,
Hales

This might sound weird but worked when I had this issue:

  1. Turn off HMD with the power button on it
  2. Unplug your HMDI cable from computer
  3. Plug back in the HDMI
  4. Power on HMD

I’m not sure, but according to this, SDK 1.3 is not supported yet:

It works for me (positional tracking is funky though)…I have 0.8.0 installed so It might be the sdk 1.3

Ah phew… other people with the same issues…

VR Preview “greyed” out…

I was installing 4.11 as my machine then decided to reboot and install Windows 10 (from Window7)… what a hell of a night !!!

Really hope this is fixed quick as I develop in Unreal with VR !!!

Same think over here, but with DK1 and SDK 0.8 : Back screen, it was NVIDIA 364.72 Drivers fault…

So i went back to 361.43 and everything is fine. :rolleyes:

Well you all are lucky at least the Rift is being detected. UE 4.11.1 has decided to no longer recognize my oculus while 4.10 works fine. Anyone got any ideas I am going to try that unplug replugin suggestion and maybe sacrifice a goat to the CPU god… ← just in case -NO this is a joke-

Just here to verify that 4.11.1 is preventing my Vive Pre from being recognized in UE4.

I am also having trouble with my Vive. 4.10.4 blank project and it works fine - 4.11.1 and no go. It does flash the headset during the loading of the project. The vr preview viewport is no longer has the black bars on the side - not sure if that’s from trying to have a friendly observer view or what.

When trying to use the VR preview in 4.11.1 on my DK2, I just get a black screen in both my rift and in the gameplay window. I have SDK 1.3 installed. Is anyone else experiencing this?

Upgraded to 4.11.1 and VR preview is grayed out as well!!! :frowning:

Alright, got it working. Had to uninstall old runtimes. Install the new oculus runtime for the consumer version. Setup Your Oculus: Quest, Quest 2, Link, Rift S & Rift | Oculus then open the new oculus control app. (just load the oculus.) then go to settings>genera and turn on the “unknown sources” to allow it to run in UE4 4.11.1 VR preview should be back.

me too :frowning:

I wonder if i can downgrade project to 4.10 ?

The issue needs a little more attention than it’s had to date. Has anyone heard anything from Epic?

As for the Oculus, this destroyed my VR development until I get something else. Which sucks because I have been developing a VR game for over a year now. Basically 4.11.1 updated to the 1.3.0 sdk for Oculus. Oculus no longer has a separate run time and sdk. The sdk is still dl’able but you have to setup with the new run time through Oculus setup. Which then cries that you are using a measly 300 dollar DK2. Then you have to sign in to oculus and be online or you just get a blank screen because they can just turn off your headset in conjunction with a long line of draconian terms of service and privacy issues. Can’t say I didn’t see this coming when they partnered up with Microsoft…

Same here, still fine in 4.10.4 and in SteamVR itself. Made sure that all my firmware is up-to-date as well.

This worked for me but the rift viewpoint is at the feet of the character and turned 90 degrees to the left. It’s probably a settings issue - is there a way to fix it in the new runtime app?

Edit: There kind of is. If you’re a DK2 owner then you’re in for a world of hurt. Reboot your machine and find a controller with A and B buttons so you can complete the setup.

You must have the camera, HMD, and a controller detected for 1.3 to work. You can use a normal gamepad.

It was entirely that it wasn’t calibrated. After a reboot, locating a controller and doing some setup everything worked fine. :slight_smile:

That got it working for me, thanks! Also for those playing along, the preview shows up after putting the CV1 on your face to turn the device on.