Download

Improper reflections in polished tiled floor?

I have set up a library room with floor material having a very low roughness so as to make it polished. Problem is the screen space reflections a bit off, as visible in the two screenshots below. The first screenshot has the viewport camera at the usual height, the second has it just close to the floor. You can notice the change in the window reflections. Issue wasn’t solved even after including the reflection capture box. I don’t want to use the full blown planar reflection object, as this issue will arise even for materials with a little more roughness but still showing reflections.

What possible solutions do I have? Or is planar reflection the only way?

Troubleshoot1.PNG
Troubleshoot2.PNG

Make sure SSR quality is set to 100 if it isn’t already.

For a perfectly flat mirror polished floor, a planar reflection is probably the best option.

SSR isn’t great for mirror like surfaces, it’s one of its main limitations. A tiny bit of roughness and normal distortion can easily and quickly cover up those limitations.

Awesome, it worked. I was really looking forward to having the reflections like in the first screenshot, however, this result is great as well given I really don’t want a planar reflection. I also did [FONT=Lucida Console]r.SSR.Quality = 1 in the console; read it somewhere on answerhub. The overall effect looks pretty fine quality.

You can enable and use Planar Reflections as well. Search the documentation to see how to enable and use it to get the mirror-like reflection that you want.

Thanks! For my current scene, the issue seems resolved, but I sure will look into Planar Reflections to see how it can enhance the effect.

Thanks! For my current scene, the issue seems resolved, but I will look into Planar Reflections to see how it can enhance the effect.

This actually does the opposite^^ It works kinda like this:

  • Under the hood, there are console these commands: r.SSR.Quality=1 or 2 or 3 or 4. 4 is the highest possible quality without tweaking shader files.
  • In the Engines Post Process Volume, you have SSR Quality 0 to 100
  • Those number roughly translate like this: quality 0 to 25 is equal to r.SSR.Quality=1
  • Quality 25 to 50 equals r.SSR.Quality=2
  • Quality 50 to 75 equals r.SSR.Quality=3
  • Quality 75 to 100 equals r.SSR.Quality=4

HOWEVER, per default, the console settings are r.SSR.Quality=3 which means that even if you put in 100 in the post process volume, you will only get quality level 3. To unlock the 100, you need to type r.SSR.Quality=4 into the console or into the console variables file to always have it like that when you start the engine.

Using r.SSR.Quality=1 actually gives you the lowest quality of SSR and between quality level 1 and 2, SSR doesnt even support proper roughness! So to get slightly varied or glossy reflections, you need a quality level higher than 2. If you are lower than 2, you will ALWAYS get mirror like SSR no matter what roughness your material has.

Also, SSR are actually better suited for mirror like reflections because they become quite a lot more expensive the more rays they shoot. To have proper roughness support without a lot of noise and errors, you need to shoot quite a few more rays, which is why quality 4 is not enabled per default! It looks really good, but I would argue that you can only use it for archviz and portfolio stuff since the effect then becomes way too expensive to ship a game with it.

Hope this helps! :slight_smile:

Yes, I actually got that once I dug into it, which I did after posting the reply. Good point about the console variables file.

This was news to me. Maybe I will stick with quality 3 once we get to the shipping version.