Download

Importing VR template in existing FPS level?

Edit 2 : part of the problem solved. See scond post for details

Edit : Been able to import the VR template in my existing project (add new > new features. The VR template is in my content browser now? How do I configure it, now?

Hey guys,

here is the thing. I made a level with the FPS template. Works fine, I’m happy with how it goes.

I would like to take the motion controller template from the VR template and put it in my FPS template.

In the ideal world : I put play with the regular buton the FPS template starts and I play with my controller and regular screen on FPS mode.

I put play with the VR logo, the VR template starts (I can’t stand the controller way, make me sick, love the teleport thing…) and I can see through the headset.

I tried the integrated VR in the FPS template, but I don’t have the teleport, I have to move with controller (and my pawn is below the ground…).

Hope you understand what I am talking about,

Thanks

Pierre

Edit : moderators, I puted this post here, I think it’s a better place than content creation. Feel free to kil the previous topic if needed. Thx

Hi Pierre,
I hope I understand what you are trying to do.

To use the teleportation VR pawn in your FPS level, you need to swap the FirstPersonCharacter pawn with the MotionControllerPawn from the VR template.

After you have imported the VR template content, delete the FirstPersonCharacter pawn from your level, place a MotionControllerPawn (make sure it is flush to the floor like in the original VR template), set Auto Possess to Player 0.

In order for the teleportation to work, you need to place a navigation volume in your level. Drag in a Nav Mesh Bounds Volume and set it up (press P to show it) so it covers your floor properly.

That’s pretty much it.

Cheers,
Marco.

OK, so now I’va got the VR pawn on my project. Starts with the right spot, and the right size (feels great!).

The only problem is I don’t have anyteleport possible via motion controllers, or any interaction.

Help?

You absolutely understood it.

I have to find the navigation volume now…

Is that the MotionControllerPawn? Did you create a Navigation Mesh as I indicated above? That is necessary for teleportation. If yes, can you post a screenshot of it?

There is actually something I forgot. You also need to copy/replace the inputs in the project settings.

Do this:

  1. Create a new empty project from the VR template
  2. In this project, go to Edit → Project Settings → Inputs
  3. Export the inputs (there is an export button top right). Save the file somewhere.
  4. Open your project. Go to Edit → Project Settings → Inputs
  5. OPTIONAL: delete all the inputs Axis and Actions. This will keep your project clean.
  6. Import the inputs from the file you created previously.

That will give you the necessary input events to use the motion controllers which would be otherwise missing.

The navigation volume is set. This is what I’ve got, I think, it’s done for this part.

https://forums.unrealengine.com/filedata/fetch?filedataid=136343

Now; I’m gonna export and import the input as you explained.

Keep you in touch in a few minutes.

Looks good to me! It should work once the inputs are properly set.

VR Marco, you are indeed my Champion!

Everything works GREAT!

I really really thank you, you’re awesome!

Cheers.

Pierre

Well done! You are welcome.

Hi Marco ,

I was searching the answer about VR input, Found your reply thanks for that. this action inputs use for all ( Oculus and HTC Vive ) ?

i will buy Oculus for my VR Project based on FPS Character.

Oculus is not suitable for motion controller map in VR template ? videos show that for Oculus Rift i need to use HMD Map Template ?

Thank you

The input mapping mentioned above was exported from the standard VR template and it works both with the Oculus and the Vive.

To work with the Motion Controller Map you need the Oculus Rift + Oculus Touch (Oculus’ motion controllers). If you don’t have any motion controller, then that map won’t work.

Marco,

You’re my champion too! was looking all over the internet for this issue.

Thanks a ton!!

Am interested to do the same , but am sorry to ask u guys for a more clear steps as am a arch visualizer with very week experience in unreal engine blueprints . am just asking for more clear steps , and thanks for trying if u cant ,

Regards

if no interactivity except game controller:
Make sure your ‘Project Settings/Inputs’ are setup for Motion Controllers! That the Move Forward has a ‘Motion Controller’-R-Thumbstick Up’ entry etc.;. In 4.24 you can now easily select ‘grip’ as Trigger on Vive wands, but Trigger button on Oculus Touch and/or Valve Index controllers! in the same build…
. For this reason, it is a lot easier now in 4.24 to do inputs! As Marco mentioned, you can export the Project Input Settings (upper right in P.Settings) then import to your new Project, but be aware of the HUGE input changes above between 423 and 424! :slight_smile: (Motion Controller general settings are deprecated,n replaced with individual Motion Controller brand/layout choices!)

**Isn’t Marco is a God in VR, I am so appreciative of his help even though I get frustrated sometimes,. I hope he doesn’t think I’m rude or selfish,… (just passionate!).
I’m going to donate a real percentage of all my early games earnings, to him or a charity of his choice. No one stands out like him for sharing selflessly in VR…

. I did the same sort of thing with an outstanding Autodesk forum ‘employee’. that helped me extensively always going above and beyond. With his laser guided help, I got a TV show as Animation Supervisor for years, then later got to work in Film doing Hair FX for over a year on a stereoscopic 3D movie called Life of Pi 2007. I bought him something… Extravagant! I then spent many years at Activision… Those were the days,…
But now with VR; THESE ARE THE DAYS AGAIN BUT BETTER THAN EVER! **

2 Likes

Hello vr_macro,
Just saw your replied and I will say I have the same issue under 4.26.
I did a project with basic Vr setup but I will be keen to grab the one from the template to get more functionality.
I’ve tried all of that even from a fresh FPS project but no controller are working.
I’ve imported the input but still nothing is working.
Do you know what can be the issue, please?
Thanks in advance
Cheers,
Matthieu