Importing static mesh from Blender to UE4 looks pale and somewhat looses details

Newbie here, I’ve been working on a game model in Blender and it came out amazing and I was going to test the models scale in UE4 before I animate it but after importing it (.fbx file, I imported the Static Mesh and the Textures Separately) it looked really really bad and pale. My model in Blender is great aside from the seam issue that I still have to fix but other than that it looks great
I tried changing the light settings and fiddling with the normals in an attempt to restore the details but doesn’t seem to do anything.

Did you apply all the modifiers before exporting? A screenshot of your export and import setting would be great. And most importantly, can you show a screenshot of the material?

Yep I apply all modifiers before I export and I also remove all the materials and texture before I export replacing it with a regular lambert because for some reason if I export it with the materials importing it to UE4 hangs (idk if this is relevant but maybe this detail will help


These are the import settings from Unreal. They look fine, except it would be awesome if you can click on the triangle under Mesh, so we can see the important stuff. Also don’t forget to show us the export settings from Blender and your Material setup in Unreal!

From the smoothing group error, you probably forgot to check Face/ Edge Smoothing in the Blender export settings. The other missing screenshots will probably tell why the skin looks pale.

Oh sorry didn’t realize that some of the pictures didn’t attach, here is an update
I checked the smoothing in Blender and got rid of the error but still looks pale

Make sure enable sRGB in your texture in Unreal. Also, Unreal uses a PBR shading model, so you actually need a Metallic and Roughness map. In your case you should get away with a Metallic value of 0 and a Roughness value of 1. Just in case, always export from Blender with Tangent Space checked in.

It must be something with your texture. It looks different in the Material Editor when comparing to the Content Folder. There was another question where someone mentioned he used 16bit PNG. You could try to export the image in 8bit and import to Unreal again, but this is the last solution I got <3.
*Except checking if your Skin Texture Sampler Type is set to Color.

Ok I was able to add Metallic and Roughness and I also enabled all sRGB in my textures except for my normals which for some reason won’t let me and I re-export and import my fbx. file with the Tangent Space on and still is pretty much the same, still pale

Sorry for the very late reply having some login issues with epic.
Anyways I exported my base color as 8bit and checked sampler type to color except for the normal map which wouldn’t let me and it worked, the color is there now, I don’t really understand why though but it still looks far from how it appears in Blender, it still keeps the flat look from my previous image, sorry couldn’t upload a sample right now I am updating mg UE4 so I can’t take those screen shots, well I got 1 problem so thanks for that

You can make a Scalar Parameter (so you don’t have to recompile every time) and change the roughness value between 0…1 and see if you can get the same result. Same goes for metallic.

I haven’t gotten a decent result yet, I have been researching a lot and apparently have no luck with it yet. I decided to drop it for a much simpler look since photo realism is a very very hard thing to do for an indie dev. I thought my expirience with my 3d modeling and animation class would help me achieve that but It looks like its impossible for me right now.
I appreciate the help though, I at least learned that my textures should be in 8bit rather than 16bit

Is the green channel wrong in your normal map? Blender and UE4 use the green channel differently. Try double clicking on the texture, click the drop down arrow under Texture and click the Flip Green Channel button and see if that helps. (doing it by memory so I could be a little off)

If I’m imagining that option you can also open your material and multiply your normal map by 1, -1, 1.

Also first post here so I hope I’m submitting this correctly. <__<

Wow that seemed to do the trick look it looks exactly the same as the one in blender, Thanks everyone you both helped me get to this result. Is there anyway for me to check both of your answers as correct cause it won’t let me

Just mark this one, you already wrote a hint that my stuff was helpful.