Importing models with textures from Blender

Hello forum!

I’ve recently just started working on 3D modeling, and I’m still quite new to both Blender and UE4.

I’ve made a basic chair, and inside Blender I’ve UV mapped it, and applied textures to it like this:

But whenever I import this into UE4, I don’t get the textures applied, and it looks like this:

I’ve looked for various tutorials and best practices online, but can’t seem to find anything that works.

I’m hoping that some of you guys could help me out?


I do have the “Import Textures” and “Import Materials” checked in the UE4 import settings

I would guess that it is one of two scenarios:

  1. You have textured your mesh but it doesn’t have a material assigned in blender. You can view a textured model if you are in the texture display mode even without a material assigned. Does UE4 create a material for you in the content browser? If not then this is your issue. Use the FBX exporter in blender if you aren’t already.

  2. Potentially an issue with filepaths. I haven’t encountered this though because I always keep my textures in the same directory as my .blend files.

Make sure that you have a material assigned in blender first and try to import/export again. If that doesn’t work I would just manually import your textures into UE4 and create a material yourself. It doesn’t take long and will save you the headache of troubleshooting the issue :wink:

I do have a material applied in Blender, and it does crate a material in UE4. You talk about the FBX exporter? I’m not sure what this is, but I’m exporting the model from Blender as a .fbx file?

im gonna look into this for you right now

Hello Detilium, I tried to recreate your issue. After importing the model and textures did you save them before trying to put the object in scene? When importing this way the material is not compiled until you do and wont show up

yes please do i can look at it now. Yes that information is stored in the fbx I generally dont import my textures this way as I use a variety of other programs to make the texture and load them all up into an actual shader. But I did apply a texture in blender and exported it to ue4 and the material showed up applied just like i had it in blender so i will for sure need to see what your setup is =)

Textures will appear as a separate icon in the content browser. Double click your material to see if your texture is linked up in the material. If your textures don’t appear then import the images manually for a quick fix.

think i found your problem and yes beast hacker is right you dont have the texture assigned in texture tab

Appreciate it. I could put my .blend, textures anf .fbx files in a dropbox link for you?

I just tried, but with no success. Bare in mind, I’m still not importing the textures on their own. I believe these information would be placed in the .fbx file?

Here’s a link for the files: https://www.dropbox./sh/4q9m6ibj5bxw2c9/AABAzDXeCTgab6LCYp2UAv3wa?dl=0

As a separate icon? Then the textures aren’t being imported. I haven’t really worked with materials in UE4 yet, so how exactly would I apply the textures? Bare in mind, this chair has to textures: one for the seat, and one for the rest

lookey here in picture… so click on the red and white checkerd tab then click new and name it if you want. then selct image or movie next here is the tricky part. You can click the file and browse to your texture OR if you already have it like you do in your uv editor you can click the little file next to image or movie and itll show you all the images already loaded into your blend file and you can choose the texture map here and it will load. Then save your fbx again and reimport

Problem is that you don’t have a texture on your material in blender. I just checked out your file.

To get things working how you want you’ll have to do the following in blender.

  1. Create another material for the seat cushion. Go into edit mode and assign the vertices for the cushion in the material panel in properties.

  2. Now you’ll need to add the textures to your two materials. Click the checkered box icon right next to the materials icon in the properties panel in blender. Click new to add a texture and under the ‘Image’ section to select the texture for each material

its not a bug you need a light in scene of blender for materials to show up in material mode

nevermind your right. before you needed to assign a material to assign a texutre but now they have it seperated. strange

I think this is a Blender issue. When I look at the chair in Blender with “material” mode, the chair is simply white, but if I look in “texture” mode, the chair is textured.

I apologize for asking Blender option in the UE4 hub, but you say “assign the vertices for the cushion in the material panel”? Could you elaborate? I’m not sure how to achieve this.

I’ve tried selecting the faces for the cushion, then create new material, and hit the little button that says: “Assign” right above the material name, but that simply changes the entire chair’s texture?

Emphasize on SHOULD :slight_smile: - It just textures the entire chair

That’s the correct button. You’ll need to be in edit mode and ensure the right material is selected when you assign. Select everything except the cushion, select your wood material and assign them there. Should work.