Importer breaks after 1 import

I import a mesh with animations. Skeletal Mesh is ok. Animations work ok. Output Log has no errors. Brilliant.

I take the SAME FBX I just successfully imported, and import only the animation, immediately gives me this error. Anything I do from this point onward is doomed for failure. Output always tells me:

Source Global Transform (30.546658,0.000001,38.034245|0.000014,90.000008,-1.037880|1.000000,1.000000,1.000000),
Converted Global Transform (30.546656,0.000002,38.034245|-1.037874,0.000010,89.999969|1.000000,1.000000,1.000000)
LogFbx: Warning: IMPORT TRANSFORM ERROR : Bone (Jaw_L:56)
Source Global Transform (34.568314,-19.652735,36.605602|57.796661,-7.135368,-130.053772|1.000000,1.000000,1.000000),
Converted Global Transform (34.568314,-19.652731,36.605598|-24.074408,37.679100,-22.062201|1.000000,1.000000,1.000000)
LogFbx: Warning: IMPORT TRANSFORM ERROR : Bone (Jaw_R:57)
Source Global Transform (34.568317,19.653002,36.605618|57.796619,7.135294,-49.946331|1.000000,1.000000,1.000000),
Converted Global Transform (34.568314,19.653002,36.605625|-24.074490,-37.679096,22.062185|1.000000,1.000000,1.000000)

All of my joint scales are 1.0.

And get this, DELETING the imported file (mesh, skeleton, physics asset, everything) and doing a clean Import, will always fail as well. HOWEVER, restarting the project fixes this, I can import once and then it breaks again.
I also can’t restart every import and accumulate successful results, since it only works if a skeleton isn’t present.

I’ve scoured the web, and most complaints are resolved by fixing joint scale. I triple checked mine, they are 1.0 all of them.

Result with fresh Import:

https://puu.sh/yYFFG/ad1cbb568c.jpg

https://puu.sh/yYFFG/ad1cbb568c.jpg

Result with a secondary import:

https://puu.sh/yYFjn/19ffefb7f6.jpg

https://puu.sh/yYFjn/19ffefb7f6.jpg

(Same Frame)

I’ve tried this with exporting FBX 2015, 2016/2017 and 2018. Both split up individual hierarchies with animation only, and a full FBX with the geometry, joint hierarchy and animations. I am not able to fix this in any way.

Sometimes the results are different. Occasionally upon importing, the error will convert X to +/- Y, but that is very rare. Out of 8 hours iterating the export/import between Maya and UE4 in EVERY way I could think of, exporting separate pieces of the mesh, just the skeleton, full mesh, animation only, partitioned animations, nothing solves this. Tried all sorts of Import settings, no go still. T0A’s, not updating poses and the likes.

This happens in 4.18, but does not in 4.15.

Please try Importing this fbx:
https://drive.google.com/file/d/1erc...ew?usp=sharing

Hello,

We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://forums.unrealengine.com/unreal-engine/announcements-and-releases/1410408-unreal-engine-bug-submission-form

Thanks

Hi,

It looks like there is an issue with the skeleton itself and not the engine. See in the Output Log:

LogFbx: Warning: Not valid bind pose for Pose (skinCluster2) - Node Doodads : The relative matrices do not match
LogFbx: Warning: Not valid bind pose for Pose (skinCluster2) - Node BadassSpider : The relative matrices do not match

This would be a starting point.

-Thank you

As mentioned in my post, this doesn’t occur in a brand new project, or any other project really. I’ve done every possible test I could think of. I have read the log as well, it is not very helpful. In any case I have reported it including the project with every fbx version and export that I tried, all of them breaking.
I consider this matter closed since replication is probably very difficult.