Download

Imported models appearing black in my environment?

So far, all of the models I’ve created with the new Quixel Suite appear black when I import them into my environment. They appear fine in the static mesh viewer within UE4 (and in 3Do), but once I actually place them I cannot see any texture as the material shows up black. I imagine that it has to do with something in my environment because the models look fine on the pre-built example maps. Additionally, all of the models have separate lightmap UV channels. Is there something that I need to do differently in lighting my environment?

3c9971db4ceab8fe91d6f421ae9cc851a2f7f1fe.jpeg

HVavMDm.jpg

Have you put a Lightmass Important volume into the level and adjusted the Lightmap resolution for the mesh above the default 32?

Create a 2nd uv channel: http://www.youtube.com/watch?v=z5yc-bKbHyc

Just tried that, didn’t seem to have an effect. I set the resolution to 64 and couldn’t see a difference.

In regards to the second UV channel, all the models have one and they work fine in the prebuilt example levels. No overlaps or anything.

Is it still black after you have placed a point light near it?

Yes, it doesn’t seem to have any effect.

I have 8 point lights in close proximity to the railing model which I highlighted in this picture:

4748e21cb7386a10ec90c0aa1a394bcd5bb0726d.jpeg

The door on the right is also experiencing the same problem.

Recreate the material of the mesh without any specular, metallic and roughness settings. So just plug the texture into the diffuse and then assign the new material to your mesh. Now check if it still black

That seems to have helped a bit, the material no longer appears entirely black. Would the ambient lighting of the external environment have an effect on reflective models, even if there are point lights nearby? The outside sky is black.

b6ab77996d195c2e5565e6183c155aa40b412578.jpeg

Should I be using a directional light as well as point lights? This is an interior environment so originally I had not planned on it.

Use reflection capture actors + a lower value for the rougness

Hmm, at first I thought that was working. I added a reflection capture actor and increased the attenuation radii of the lights and things looked good:

a92dba224732e69ade670ce3b6dcd2a2a2a70241.jpeg

But then I built the lighting, and the model appears black again:

5d5864d99ac4f66013159a529b1bf1555c043933.jpeg

At the moment the model has no roughness value.

Are you 100% sure that you have a 2nd uv channel with a proper lightmap? -> because exactly the same happens with meshes which dont have a proper 2nd uv channel (they also turn black)

The Map Check log doesn’t show any errors for the lightmapping when I do a lighting build.

This is what the model UVs look like. Both UV channels are the same.

55dc844094d0f3caadf7b1c1f5148d62385bc301.jpeg

Hmm, pretty strange -> is it possible for you to upload the mesh so that I can take a look at it?

Btw, for those which are interested: Here is the link to the answerhub question ^^ Why are imported models appearing black after the lighting build? - UE4 AnswerHub

Here’s the FBX with all the associated textures:

Ok, I will take a look at it :slight_smile:

Ok, it definitely has to do something with your light setup in your level, because atm I’m not abel to reproduce your problem:

light.jpg 1 Point Light in a BSP room + M_Metal_Steel Material

So you just have point lights in your level? -> Could you also post a picture with their settings? Add a skylight with a low intensity into your level -> probably you will see an effect. Also copy everything into a template level (so not into a blank map)

If I understand how they work, wouldn’t a skylight not have an effect on an interior level, because the level geometry will block all incoming light?

These are the settings I have for the point lights in the hall segments:

light_settings.jpg

Interestingly, the grate is still black when I load it into the example map and do a lighting build. Before building the light the grate looks metallic. It also has a separate UV channel for lightmapping with non-overlapping UVs. Both models have the “M_Metal_Steel” material applied.

411531f9b6978c116ff5966ba9c21e4e177e6bdf.jpeg

Just directional lights wont have an effect on an interior level. A skylight adds a “ground lighting/brightness”.

When you add a little bit of emissive in your material is it still black after the light build?

I plugged the specular texture into the emissive node to check, and after building the lighting, the material looks the same.

c75268ff529d1a6bc6caf16d1551773fbb2e4c07.jpeg

You have to add your diffuse + a constant vector to a multiply to get a good emissive :slight_smile: But your texture is really dark -> connect the diffuse + a constant vector (value of 1-5) with a mutliply and the multiply to the diffuse.