Download

Imported model overlaping cloth problem.

Hello, I am having a problem importing a daz character.
The problem is in Unreal Engine, since as shown in the picture, the simple Windows 3d Viewer opens the model correctly.
I’m not sure what the problem is.

is this something related to morphs?
Can anyone help me?

Thank you!

Game engines have limited depth buffers, stuff that is very close together (like one surface just in front of another) can end up in the same depth which causes z-fighting. You may need to do work on your mesh to avoid areas overlapping, so rather than having the outer pieces on top of a nude model you would just have the outer pieces. That’s something that’s often done in games where the character won’t have the parts that would be obscured by clothing.

OK I understad. Thanks for the info!

Let me screen my Daz3D Export Settings.

This will export several key morph targets for you character. Notice under Morph Targets whether the item is set to Export or Bake.

Export will yield morphs you can use in engine.
Bake will permanently apply them to character.

Hope this helps.

Thanks for the response @Wxstern

this are my export settings, the cloth is shown as a “Prop” i dont know if this could make a difference.

However if @**darthviper107 is**right, I will need to mask the skin in the Material or fix in an external tool.

Its interesting your clothes are set to prop. Are they fitting properly within Daz?

Yes they work just fine in DAZ.
I didnt notice but the cloth (Props) are not even rigged.
I think the problem is related to the fact the the cloth are Props

How are you adding the clothing to the character within Daz?

Just selecting the base model and adding it as normal cloth from the warehouse.
With “Normal” cloth everything works just fine. the problem is this props category.

Funy thing is that you dont even know if what you are buying is a cloth or a prop

I recommend selecting the geometry for the body that’s under the clothing and moving it to it’s own surface group in Daz Studio. Then in Unreal you can assign a material that masks it out. I have some instruction here Daz To Unreal – Hiding Figure Geometry – David Vodhanel
They don’t include making the material, but I just use a simple masked material with the opacity set to 0.

To fix the problem where it’s a prop, you can try the instructions here Daz to Unreal: Fixing Accessories that Don’t Animate with the Character – David Vodhanel
I haven’t tried those with anything more than a simple accessory though.

I don’t advise doing this on a large professional project, but the cost on the main character could be pretty low, so for the Skin material do this.

Enable tessellation, fix the multiplier to 0.
Enable adaptive just so it forces it.
then take Vertex Normal multiply it times a Scalar and feed it into the tessellation.

In the material - instantiated, and thereafter in blueprint - kick the scale into the negative numbers to have the body mesh shrink.
The engine will still be rendering it, so it will cost something even though it won’t be visible, but in about 2 minutes you hacked your way into Not removing the mesh :stuck_out_tongue:

thanks a lot for your responses!
I will try the solutions and find what works better for me.