Imported Model gets wrong UV Map

Hello, I am using the engine version 4.7.0 Preview. I have 3DS Max 2015.

I got a problem with some models I am trying to import into the engine following this video tutorial Series (How to: Mesh based particle for UE4 part 1 - Photoshop - YouTube). I noticed this on Video Number 3. (How to: Mesh based particle for UE4 part 3 - Materials - YouTube).

This is what my model with the material looks like in 3ds Max.

And this is what the model looks like in the Teapot Preview, and in the Mesh editor in UE4 when I try to apply the texture.
Material Editor

Mesh Editor

Why isn’t the material being applied properly?

You can download my 3ds Max file from here.

I think you might have accidentally set a texture coordinate node to 2 on the Y scale??
I checked the mesh in 3dsmax, and it looks fine.
After importing it into ue4 and applying the version of the same material I made for the tutorial the texture also looks fine :slight_smile:

That’s not it. Here is my version of the material I made.

To finish the tutorial, I used the tail models you made (From the video description) and I used those with my materials. So, I know the materials are right. I had no problem importing in your models.

Hey Motanum -

Luos already mentioned the first thing to check, but you might also want to go into Max and in the UV Editor, and see if you have inverted faces any where. That would be the most logical thing to check after the Tex Coordinate.

Let me know -

Eric Ketchum

I just double checked that for for him, but that seems to be as it should be.

Hmm, I cant see anything wrong after double checking your mesh.
Try this one: Dropbox - TesterMesh.FBX - Simplify your life
Its your mesh, just exported it again.
If it works it might be something strange in your export or import settings :confused:

Hey If you don’t mind could you send the FBX of your model for us to glance at?

Thank You

Eric Ketchum

That one does work properly as seen here.

I can export other models with their UV properly set, as you can see on this edited FUSE model.

Trying my own again after exporting other models yields the same result.

These are the Export Settings.

I will tick yours as solved. I think this is just some weird case of my 3ds Max. So far every other model has behaved properly, so lets hope it’s just some weird, one time hiccup.

Sure thing, here is the FBX.

Thanks, I am not a super pro with 3ds Max yet.

Try this (for regular meshes):
(also, fbx 2014 is now also a viable choice)

No. It still is the same.

Could it be a property in the Details in the Mesh Editor?

Hey Motanum -

After looking at your model it looks like the rotation of your UV was causing you issues when importing, so it was not inverted but the vertices in the UV space where not aligned correctly to the U and V (X and Y).

Eric Ketchum