Download

Imported meshes get darker after Building Lighting

Hello.

I’ve made this mesh in 3ds Max:

294139a028235437cb254de1688646d1a330bb5f.jpeg

When I import it inside Unreal Engine, after Building the Lighting, it gets darker:

f.png

I just need to move the object a little bit to reset its normal color

aee5826e91a7f0c971190ad4cc3a719d6f659cf5.jpeg

But then, it asks me to Re-Build Lighting again.


I was told that I should give my models a UV to work. Well, these are the UVs for the Box and for the Shells

BOX

7483f44e0ac8207f33efedba8eef9283b56570c7.jpeg

SHELLS (i just show one shell, but other ones have the same UV map)

sh.jpg


Inside the Engine, the UV of the entire model looks overlapped!

t.jpg

The mesh gets darker because it’s baking the lighting and adding occlusion and GI to the lighting of that mesh. There are some artifacts (the dark spots) because your light map resolution is probably set too low. You could set the mesh to moveable instead of static, and that error will go away and that mesh wont get baked lighting.

I set the LightMap resolution to 128.

  • Is it good practice to **increase **it more?
  • Is it good practice to set a mesh Movable to escape from this issue?
  • Is it good that I see the UVs of the Box and the Shells **overlapping **just because they all belong to the same exported .fbx object mesh?

Thanks.

The more complicated the mesh, and the larger the mesh, the higher the light map resolution needs to be. If it was just a box or a few bullet casings, 64 might be fine. But for a wall or statue, 1024 is totally fine.
Movable meshes should be mostly reserved for things that move, unless you want your entire scene to be dynamically lit (like a day/night cycle). But that’s a whole other discussion. Things like ammo pickups would often be movable meshes.
Yeah the overlapping is expected, the second UV channel (UE4 starts counting at 0 so channel 1) will have your light map UVs, and those should not be over lapping.

The problem is, with that very simple mesh the LightMap Res. to 64 used to generate that dark effect. I increased to 128 and the result is the same. So as you can see, 64 hasn’t been fine for that box.

My entire model is composed by a box and 8 shells. Each object (8 shells + 1 box= 9 objects) has a not-overlapping UV.

The problem (should I call it problem?) is that Unreal Engine takes all those UVs and puts them together in one UV.

It’s a box with 8 casings, there’s a lot of surface area that the light map has to cover. 256 would be reasonable for something like that, If it was just a closed ammo box, 64 would work.

It’s fine if they are over lapping in UV channel 0 which is used for texturing. If they are over lapping in UV channel 1, which is used for light maps, then it’s an issue. UE4 treats a model as one static mesh. The gun from Epic’s shooter game content example has overlapping UVs, because they are using 2 textures for the model (kind like your ammo casing with the box and the shells). This isn’t an issue because they assign a different material to each part.

If they are not overlapping in channel 0, why should they in channel 1?

If I understood correctly, the channel 0 is composed by ALL the UVs of ALL the meshes in my whole object.

And the channel 1? Who makes it? Who determines it?

It’s just something to check when you are having light map artifacts.

Yes, channel 0 will be every channel 0 from every object in your static mesh.

UE4 automatically creates a light map UV for channel 1 unless you disable it, or if you are using multiple UV channels for other reasons.

Thanks for the help. For now, it is enough :stuck_out_tongue: