Download

Important Lightmass Settings missing from Foliage Tool

So today I’ve noticed there are a number of important Lightmass settings missing from the Foliage Tool’s Static mesh instance settings - most notably:

  • Use Vertex Normal for Hemisphere Gather (This one is super important as a lot of foliage uses bent vertex normals to look volumetric)

  • Use Emissive for Static Lighting

  • Use Two Sided Lighting

  • Shadow Indirect Only

  • Diffuse Boost and Fully Occluded Samples Fraction on instances also

My question is why aren’t these options available for foliage instances in the Foliage Tool? Is there a way to tweak these settings for foliage instances? Right now this is causing me a huge headache when trying to get painted foliage to look correct with static lighting and I cannot consider placing thousands of foliage meshes manually.

Is this an oversight or intentional?
settings.jpg

Also posted on Answerhub, any help would be much appreciated: Important Lightmass Settings missing from Foliage Tool! - UE4 AnswerHub

I’ve been told I could create a blueprint and set the static mesh lightmass setings from there, but im wondering if using blueprints in the foliage tool will prevent batching/clustering of instances?

Ok I have been searching all day and haven’t been able to figure out how to place blueprint foliage with the foliage tool, can anyone point me in the right direction? This issue is has ground my whole project on halt right now, without being able to set lightmass settings on foliage I cannot proceed :frowning:

So after a little more digging it seems that you can create a new BP which inherits from FoliageInstancedStaticmesh by clicking the + next to the Component Class in the Foliage tool, and then you can edit the initial values of your class:

prole.jpg

Unfortunately the Lightmass settings are greyed out! I have been racking my brains and trying to find help on how to fix this but have had no luck so far. I also found an interesting node in the event graph called Break LightmassPrimitiveSettings but cannot find a way to execute it. I feel like im getting closer but have found yet another roadblock.

Can anyone help?

Ok so I ended up figuring this out for myself after much pain and some help from friends - basically, the reason the Lightmass options are greyed out in the initial class values is because the mobility of the instance in the BP is set to movable by default, making the lightmass settings mute. To fix, simply scroll up the the Transform section and select “Static” from the three listed options:

6b590c071f8683e5b54c46a7b910f85c675c5bcf.jpeg

Now you can select whichever Lightmass settings you need!

Hope this saves someone some time in the future!