Import mesh weird face normals

I have a weird Problem with importing fbx meshes into Unreal with the correct face normals. I tried everything at this point and cant seem to get it working without using datasmith. I would like to find a fix for my problem, since Ive done quiet a lot of work I would have to redo instead of just reimporting the fbx models.

So, here is the Problem. When I import FBX meshes, it does not seem to correctly import the face normals, so the shading looks pixelated and wavy instead of a smooth surface. I use c4d for the export, tried all the settings in the export options. unwrapped the model. Tried the same in 3ds max to no avail.

I think it has to to with the mikk/Bi-Normals, but I have no Idea.

Engine Version 5.0.3 with raytracing

FBX is picky about “smoothing”
in blender to export to ue with smoothing apllied you have to check normal export under geo to (face) not vertex.

In 3ds max its “smoothing groups”
and I can’t remember the maya term

It has always been an issue for fbx exporters to unreal
the “smoothing” is implemented differently.

Thanks for the quick response,

However, I tried exporting directly from 3ds max with the “export Smoothing groups” under the fbx geometry dialoge.
Also in c4d, there is a checkbox for normals, but it really doesnt do anything.

Also kinda weird, if I go into the unreal mesh edit mode and select normals to fix the normals in engine it looks fixed, but as soon as I click on accept it more or less reverts to the state before.

just a suggestion
try loading the object into blender and export to fbx with normals at “face”
just to see if it works from blend
there is a trick to exporting the smoothing groups from max to fbx that I cannot remember
there are a dozen versions of fbx on export
try fbx 2015 or 2013 instead of 2022

Even with Blender the Problem still presists.

I found a solution. You have to enable “use high precision tangent basis” - That fixes the Problem.

Still a bit wonky to go in after the import and set it for each mesh.