Import Into Level leaves holes in my mesh

I am exporting my 3D meshes from Blender as FBX files into Unreal Engine 4 using Import Into Level. I choose Import Normals (and Import Normals and Tangents when I enable Blender’s FBX exporter option of Tangent Space) as the Normal Import Method in the Import Into Level dialog. I get a static mesh highly similar to the mesh I get when I import as an asset through the Content Browser’s Add/Import function (which I get no errors with), except the mesh seems to be missing some pieces of it and appears like this:

This behavior occurs for both the Blueprint and Level Actors choices for the Hierarchy Type of the Scene tab in the Import Into Level dialog.

I have exported Blender meshes as FBX with the Tangent Space option for Geometry selected and de-selected(not chosen) in the FBX exporter:


And the behavior mentioned above still occurs with the same Import Into Level options detailed above chosen.
The high poly mesh when subdivided by two levels (at 15.4k triangle count) with smooth faces and rendered in Blender with Blender’s default Eevee rendering engine shows no holes anywhere. But in Unreal Engine this high poly mesh does have holes in the nose and other areas as seen in the screenshot above. When I utilized a lower poly version of the same mesh and compared the mesh in Blender and Unreal Engine I saw no holes in any of the two programs.

I then experimented to see if higher poly meshes were giving me issues in Unreal Engine by exporting a one-level subdivided mesh with a 3.9k triangle count and found a hole on top of the nose when rendered in Unreal Engine and even after triangulating the model in Blender before exporting, the missing nose area persisted:

So I manually edited the nose area of the mesh by diving the polygons at a further vertex so as to make the triangles bigger and not so small as in the image above, and this seems to have fixed the issue and Unreal Engine now renders the full mesh without any omissions:

Now, the missing nose piece DOES NOT OCCUR in the original(premade asset) one-level subdivided mesh WHEN importing the mesh not as a scene but as an asset using the Content Browser’s Add/Import function. And similarly the two-level subdivided version of the mesh(highest poly of the meshes I worked with for this case) is rendered fine in Unreal Engine too without holes when importing with Content Browser’s Add/Import.

Does anyone have any suggestions as to what the issue might be with the mesh missing pieces when using Unreal Engine’s Import Into Level?
Also, why is my mesh so small when imported using Import Into Level? Is this related to the underlying issue of the mesh not being rendering fully?


holes like you say are often caused by inside orientated polys. You can check this in Blender by activating the face orientation (blue is outside, red inside). If you have red faces., go to mesh > normals > recalculate outside

personnally i use these setting in Blender for import. and so far it worked flawlessly

i never import the textures with the FBX

regarding the size of your mesh, you need to set up blender to the right meaasuring unit. You can use the measuring plugin including in Blender to check your meshes size. Be sure you activated it. UE4 unit is cms

So I checked the face orientation and it’s all blue. I then exported with Tangent Space enabled and without textures and I still receive the same areas of the mesh un-rendered:

Also I configured Blender to use Centimeters for unit of measurement in the Scene properties and I scaled the mesh significantly in Blender before exporting and importing into Unreal Engine using Import Into Level and the same behavior occurs where the mesh placed into the scene is as big as was scaled in Blender but the static mesh is still small. Very interesting behavior!

(lol Suzanne you are so big :scream:)

Also thanks for responding and for your help :star_struck:

it seems you have smoothen suzanne a lot, maybe a bit too much
regarding the scale, i don’t really understand why you have two meshes. In Unreal you import your mesh into the content library, then move it to your scene. I don’t get why you have 2 different meshes :frowning_face:

It’s still the same issue without applying smoothing to the model.

no holes, and perfectly sized here. (took me 10s)

Is it subdivided by 2 levels and imported using Import Into Level?

nope. i’m just discovering that thing to be honest :stuck_out_tongue:. just one question, are you sure this is the good way to go. it’s easier to track down bugs when you work progressively

So I can use Content Browser to import the mesh as an individual or individual assets but seeing how Import Into Level was described by this Unreal Engine tutorial course as importing your scene as a blueprint and allowing you to edit the blueprint on a per mesh basis and then saving that blueprint without having to re-import everything, I really want to rely on this workflow for future blender scenes but if it’s giving me issues with only high meshes like the two-level subdivided mesh I showed then I might be able to pull it off if I don’t go that high of a resolution or if seemingly my mesh triangles are well constructed. Hopefully someone can give me a definitive answer later but as of now I can do Content Browser so I’ll stick to that and to what I’ve tried with Import Into Level :man_shrugging:

Ok so I know i am revisiting this, however i could not find any solution myself using the suggested fixes and via documentation and research. I recalculated all normals in blender, redid the UV maps as best I could, played with all export settings and import settings.
this was the only thing i was able to do to mitigate the majority of the literal holes in the mesh (symmetrical and on the side not shown)

I have never ran into this before and i only get it with this particular model

in the static mesh details, in Build Settings, enabling the “Use High Precision Tangent Basis” and hitting apply, solved like…95% of the problem.

in second image on the rear quarter panel, there is still a small hole. however i can work around that for my purposes.

i tried playing with setting combinations in various ways and could not find any way to remove the remaining quarter panel holes

**you will also notice the wheel well somehow got choppy. and fiddling with the “recalculate normals” function does affect it minorly, however that is the only thing that is visible currently that got negatively impacted by this process, and since it is behind the wheels, it is not of concern currently

hope this helps someone in the future or my own future self

Alright, in playing around some more, i have ensured all toplogy is clean and welded where needed.
all normals are facing the correct outside orientation,

the remaining hole is facinating in that it only appears inside the Static Mesh editor

where prior, without High Precision Tangent Basis enabled, the holes would be present inside the level.

with high precision tangent basis enabled, the hole goes away inside the level

in static mesh preview window

in level with the High precision tangent basis enabled

I tried everything and i’m still getting holes in my mesh can someone please help me?