Images from DataAsset are NULL

Version: 4.8.3 Source From GitHub ( Issue has persisted since 4.8.1 source from GitHub )
OS: Windows 7,Windows 8, and Windows 10

So I have made a DataAsset for items. It contains basic item information.
It also includes a Texture2D for the icon of the texture.

After making an Item Data Asset and giving in image for it’s icon ( Texture2D ), it is still always null or invalid when trying to access it to be displayed. All other information in the ItemData Asset is just fine, only the icon ( Texture2D ) is invalid.

Here is the kicker. If you load the texture up in the editor, I suppose you call it the texture editor where you can play with the settings for the texture, it will finally start being valid and visible on screen.

I thought maybe this was just an editor bug, so I made a package ( Development Package ) and tested it there. The images for the items still showed up as white ( which means they were null or invalid )

Me and a couple other programmers have tried several different things to get it to work, but nothing does. The texture will always be null until we open that specific texture object in the editor.

So do I need to somehow LOAD the texture in blueprint??

A random data asset, You see the garbage bag texture is there. When you access this data asset, everything is there except that icon texture

1 Like

I discovered the issue. My icon was using a weak pointer. I found my answer via this link

1 Like

Thank you for posting such a detailed question and the answer to it. I ran into the exact same problem today and your post had the information I needed to fix my problem.

1 Like