Images, decals and materials not exported to gearVR

I am creating a simple first person game using UE4.9 . The problem is that when I package the game and deploy to Gear VR all materials, decals and 2D sprites vanish. They show up properly in the viewport but not in the actual game.

I have no idea why this is happening. Any help would be great :slight_smile:

EDIT: Added my log file. I am exporting the first person VR template after changing the material to walnut wood. It still doesn’t show text

Anyone who can help?

I tried exporting the firstperson template directly to GEAR VR. It worked(all textures show up). But when I changed the texture of the floor (to walnut wood material), the exported game did not render properly (grey blurry lines appeared on the floor instead of the proper material). Any help?

Hi sudshekhar -

Can you let me know what your project settings are specifically what your targeted hardware is?

Thank You

Eric Ketchum


I am trying to package my project for Samsung GearVR. The packaged apk is being deployed on a samsung galaxy edge.

Hi sudshekhar -

I would expect errors when trying to package a GearVR project on anything but an Galaxy Note 4. If you are packaging for a Galaxy Edge, try packaging without the Gear VR switches turned on and let me know if the issue remains.

Thank You -

Eric Ketchum


I wasn’t aware about it. I guess I will have to use some other software then.
Anyhow, I deployed the application after packaging it as Android(All).
Still the textures, sprites and decals are missing.

Any idea by when will Unreal engine support samsung galaxy 6?

We should support the Samsung Galaxy 6 now, did you set the Configure the AndroidManifest for deployment to GearVR as false and then try to package?

Also make sure you review the AndroidWorks setup process if you have not,

Thank You -

Eric Ketchum

My issue was resolved by packaging the project to ASTC. Anyone who faces a similar problem ought to try this out.