Im trying to get rid of these black jagged edges. any advice?

this is what i mean.

as you can see in the corner, theres this black jagged edges caused by “low” resolution lightmap. but this one is 2K and even in 4K the black jagged edges are visible. there are programs that instead of rendering invisible parts of the lightmap black, they fill the black parts of the texture with approximate colors of the surroundings.

can unreal do this?

another question, is it possible to export lightmaps, edit them, and import them back? that would also solve this problem.

or is there any other option how to solve this?

In addition to better light mapping and modeling read this thread to optimize the Lightmass settings. Lets make Lightmass EPIC (and understandable) - Architectural and Design Visualization - Unreal Engine Forums

I think on your stairs it’s because of overlapping geometry, that is a problem in UE4.