Download

I'm new with this whole crowd

Hello, I’m new with the whole game making process and such, but anyways I’m getting really irritated and can’t figure out how to fix this problem.

So I loaded up first person game mode and level and such, and was making a few things such as level design and I went to change the FirstPersonCharactter Scale [x,y,z] to [0.5,0.5,0.75]
and it like broke the collision for going up ledges and up stairs and I’m just completely stumped, could someone help me out?

Image [http://imgur.com/a/qhanG]

Also I apologize if this wasn’t the correct place to post this thread

Image link is broken. As for scaling your Skeletal mesh. Not possible in UE4. You can only manually scale each selected mesh that exists in the world outliner. If you want to permanently resize a Skeletal mesh, you’d need to export to Maya or something and scale it, and reimport into the editor. But you also might need to retarget your animations. Not sure though.

You want to use blueprints to change the scale. https://docs.unrealengine.com/latest/INT/Engine/Animation/NodeReference/SkeletalControls/

I wasn’t messing with the mesh necessarily I was messing with the capsule component, and i read that handles most of the collision and such with other meshs, would i still need to export and change in Maya? @Rallii

How would i go about changing the scale with blueprints? @MostUnholy and are you sure it will fix my issue?

Could you upload your photo in here?

If you were just messing with your capsule (which yes, is just simple character collision), then no need to export, just resize the capsule in your FirstPersonCharacter blueprint, recompile and that is it.

http://imgur.com/a/wNSvh Here is another link for the picture, the forums’ bug out when i try to insert a picture giving me an error code, and I think i may have tried that already, but it still didnt work, try explaining it in more detail plz and thank you btw :slight_smile: @Rallii

What you did is what I meant by changing it in the world outliner. That capsule is the root component in the blueprint so when that is scaled, everything that is a child of it will also get scaled. So where it shows “Mesh” under CapsuleComonent, that would be the skeletal mesh for the arms and gets scaled with the capsule.

Is the issue you’re having, is that you’re left with jumping up small ledges and stairs?

Yes that is the exact issue lol i change the scale and i no longer am able to walk up ledges or go up stairs ;-;

That is normal behaviour. Now that your character is smaller, it is having a hard time “stepping up”. If you goal is to keep your world objects larger scale than the character, you may need more of a “ramp” type collision, so the player can walk up the ramp, instead of just running into the stairs. Or maybe there is a global “step up” height/angle I haven’t seen yet. When I am back from a quick break, I’ll check the engine and project settings for you.

The whole idea is to make it feel a bit bigger so that going through doorways isn’t so cramped and I know I could just making everything slightly bigger probably but eh, this makes me bugshoot and try to figure out an idea to get around the problem instead of taking the easy way out, how would I go about making it into a ramp collision then? and would it get rid of the whole feel like going up steps tho? like the camera kinda nudges whenever it goes up steps as if you were hitting each one, and thank you for the help, did you find anything after your break? @Rallii

There is indeed a “Step Up” height value. It should be located in your character blueprint, class settings. This will allow you to step up higher then normal instead of walking into it. No need to change collision at all.

I tried changing that value to 1000, and it works with the scale being 1.0, but whenever i have the scale changed it doesnt work :c @Rallii

When you are done scaling your character. What are the new XYZ scale values you are using?

I change the values to 0.5,0.5,0.75

Ok. We’ll try something off the charts. Open up your FirstPersonCharacter blueprint and open the viewport. Instead of resizing the whole character, just resize your skeletal mesh to 0.5,0.5,0.75, and keep the capsule at 1,1,1: also resetting your step up height (not to mess things up down the line).

I figured it out :smiley: thank you so much! @Rallii

Beautiful! You’re welcome, Daevga!

I kinda have a new problem now xD I don’t think it relates to that tho @Rallii

Willing to help. Whats up?