Download

I'm lightmass stumped

Hi Guys.

Coming here is a last resort for me. I’ve exhausted all google searches and trial and error so im hoping some knowledgable party will aid me! Please help!

Some necessary screenshots…
a49ef483510bd0c4d024bad19c5677366c2235d6.jpeg
279d596177c27a1e803d8c440fd9b127f7a4b230.jpeg
daf3110529d92e77c703331207af4e1195e9af26.jpeg

Ive tried the most common things, checking lightmap texture space is adequate… bumping lightmap resolution up (Building walls are set to 512), setting build settings to production (8+ hours to render THAT btw!)

I can kinda see what is going on but I have no idea of the setting to tweak to fix it… It looks to me like there arn’t enough direct light samples and UE4 is running a smoothing algorithm on a few samples leading to wavyness… I’m getting nice crisp lines which suggests i have enough texture space but the nice shadows i get in preview mode coming through the gaps in tree leaves look just awful. There also apears to be some kind of biasing issue where 2 surfaces touch resulting in a gap in the shadows.

I’m happy with the indirect lighting, its just the direct lighting shadows that look awful.

This is like my 5th time working with lightmass and I don’t recall having this problem before… I don’t know what I broke… please help!

Here are my world settings… I even bumped the indirect lighting quality to 2 and reduced smoothness although that has no apparent affect.
5ef7e7612857eb3521b0201ff6834bd375d197a0.jpeg

Thanks in advance guys :slight_smile:

Something is messed up with your lightmap resolution, either you are not changing the correct lightmap resolution value, or the UVs for the lightmap are really small and scaled down.

You have change LightMap Resolution in mesh ?

Try to set light to use Area shadows.

As some have already mentioned you’ll want to increase the lightmap resolution for your mesh and depending on the quality level needed altering your UVs to better accomodate lightmapping may be in order as well.

Whenever it looks wavy and blobby like that that’s due to the lightmap being too small, the pixels end up big and the filtering tries to make clean edges from it.