Download

I'm having lighting problems

I am having problems with the world light when camera gets close to a texture with emissive on and also my floor is not rendering the light after I build the game it only works after I move it on the editor but after I build the game the light goes off but only from the floor. As you can see in the video.

https://youtube.com/watch?v=VNoruUwQYx0
https://www.youtube.com/watch?v=VNoruUwQYx0

Take a look at those threads :slight_smile:

Why do my static lights not showup after a light build? - UE4 AnswerHub -> deleting the \Unreal Projects[Project]\Intermediate directory.
Why does my static light disappear after build lighting? - UE4 AnswerHub -> add a reflection capture actor

The darkness issue is due to automatic exposure, since it’s getting close to something bright it darkens the image to account for the object that’s bright

If you want to disable auto exposure, set the min and max values equal to one another.

Thanks for the reply, changing the exposure worked, I had to put it at min 0 and max .1 cuz at 00 it was super bright.

For your second issue: your ground object seems very large, are you sure you have enough lightmap density? If your lightmap texels are bigger then the area influenced by the light this will happen as there is simply not enough detail to store the lighting. By moving the light it will switch to a dynamic preview which is not limited by the lightmap resolution, causing the light to be visible again.

Glad it worked out. I had to quickly find a solution to this myself when I began working in UE4. =P