Ignore objects in teleportation

Hi guys,
I’m working in a VR decoration project. It works all fine, but when teleporting i keep stepping on top of little objects, like small tables, benches…
I would like to teleport to everywhere in the room, but being able to “ignore” some objetcs. I’ve tried to remove collisions to thoose objects, but the teleporting ray keeps finding them, and it’s a weird feeling to watch the space from above the little coffee table in the corner.
Please, bear in mind that i’m kinda begginer, so maybe it’s just some small thing that i didn’t realize.
Any help would be apreciated.
Thank you.

Thanks a lot for the answer.
Setting the object to “physics only” collision was the key. Now it works perfect :smiley:

Hello NGariv,

Assuming you want to disable all collisions for any objects you have to go to the Collision section of the mesh and change Collision Presets is set to “No Collision”. This will make it so that nothing will be able to collide with the object at all.

If you want to ignore objects for you teleport, but still be able to collide with other objects (eg. static meshes) you will have to set the Collision Presets to Custom and set Collision Enabled to Physics Only (No Query Collision).

If you want to read more about collisions here is a helpful breakdown of collisions and how to use LineTrace in blueprints:

You’re welcome! I’m glad I could be of help.